summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-11-03 07:30:56 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-11-03 07:45:01 +0700
commite0c6ff70e6d9980dfa0882e475f54ea9c93f85dd (patch)
treeb5a5adb48b7c78e3fe0e842fdf22f9317cda0340 /network
parent257c9023f2f89860a2413b9b114b766b7e217215 (diff)
downloadslackbuilds-e0c6ff70e6d9980dfa0882e475f54ea9c93f85dd.tar.gz
slackbuilds-e0c6ff70e6d9980dfa0882e475f54ea9c93f85dd.tar.xz
network/SocksiPy: Removed (Use PySocks).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/SocksiPy/README3
-rw-r--r--network/SocksiPy/SocksiPy.SlackBuild89
-rw-r--r--network/SocksiPy/SocksiPy.info10
-rw-r--r--network/SocksiPy/setup.py13
-rw-r--r--network/SocksiPy/slack-desc19
5 files changed, 0 insertions, 134 deletions
diff --git a/network/SocksiPy/README b/network/SocksiPy/README
deleted file mode 100644
index 56249d3a76..0000000000
--- a/network/SocksiPy/README
+++ /dev/null
@@ -1,3 +0,0 @@
-This module was designed to allow developers of Python software that uses the
-Internet or another TCP/IP-based network to add support for connection through
-a SOCKS proxy server with as much ease as possible.
diff --git a/network/SocksiPy/SocksiPy.SlackBuild b/network/SocksiPy/SocksiPy.SlackBuild
deleted file mode 100644
index c0c62fb45a..0000000000
--- a/network/SocksiPy/SocksiPy.SlackBuild
+++ /dev/null
@@ -1,89 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for SocksiPy.
-#
-# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=SocksiPy
-VERSION=${VERSION:-1.0.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-mkdir $PRGNAM-$VERSION
-tar -xzvf $CWD/$PRGNAM.tar.gz -C $PRGNAM-$VERSION
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Add setup.py
-cat $CWD/setup.py > setup.py
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/SocksiPy/SocksiPy.info b/network/SocksiPy/SocksiPy.info
deleted file mode 100644
index 3dc23a8473..0000000000
--- a/network/SocksiPy/SocksiPy.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="SocksiPy"
-VERSION="1.0.0"
-HOMEPAGE="http://socksipy.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/socksipy/SocksiPy.tar.gz"
-MD5SUM="3be8be26230bc9eca94eb3335740ed5e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Brenton Earl"
-EMAIL="brent@exitstatusone.com"
diff --git a/network/SocksiPy/setup.py b/network/SocksiPy/setup.py
deleted file mode 100644
index f8db7bca70..0000000000
--- a/network/SocksiPy/setup.py
+++ /dev/null
@@ -1,13 +0,0 @@
-from distutils.core import setup
-
-import json
-
-setup(name="SocksiPy",
- version="1.0.0",
- description="SOCKS proxy server support module.",
- author="Dan Haim",
- author_email="negativeiq@users.sourceforge.net",
- url = "http://socksipy.sourceforge.net/",
- py_modules=['socks']
- )
-
diff --git a/network/SocksiPy/slack-desc b/network/SocksiPy/slack-desc
deleted file mode 100644
index cc4e809745..0000000000
--- a/network/SocksiPy/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-SocksiPy: SocksiPy (SOCKS proxy server module)
-SocksiPy:
-SocksiPy: This module was designed to allow developers of Python software that
-SocksiPy: uses the Internet or another TCP/IP-based network to add support for
-SocksiPy: connection through a SOCKS proxy server with as much ease as possible.
-SocksiPy:
-SocksiPy:
-SocksiPy:
-SocksiPy:
-SocksiPy:
-SocksiPy: