summaryrefslogtreecommitdiffstats
path: root/office/htmldoc/htmldoc.SlackBuild
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2010-05-13 00:39:14 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:39:14 +0200
commit0932f518b5e61e09bfc492bf4ec315ff87220db5 (patch)
tree4c9d15137e981ef8490de3a765ffdaca690335af /office/htmldoc/htmldoc.SlackBuild
parent61005da4f994e6e75f03d48f2f0de22fd2c79019 (diff)
downloadslackbuilds-0932f518b5e61e09bfc492bf4ec315ff87220db5.tar.gz
slackbuilds-0932f518b5e61e09bfc492bf4ec315ff87220db5.tar.xz
office/htmldoc: Updated for version 1.8.27
Diffstat (limited to 'office/htmldoc/htmldoc.SlackBuild')
-rw-r--r--office/htmldoc/htmldoc.SlackBuild34
1 files changed, 17 insertions, 17 deletions
diff --git a/office/htmldoc/htmldoc.SlackBuild b/office/htmldoc/htmldoc.SlackBuild
index 092643cf79..3dcaa59958 100644
--- a/office/htmldoc/htmldoc.SlackBuild
+++ b/office/htmldoc/htmldoc.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for htmldoc
-# Copyright 2009 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2009-2010 LukenShiro <lukenshiro@ngi.it>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,12 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Thanks to Gentoo htmldoc's .ebuild maintainer for hints about configure's workaround
+# Thanks to Gentoo htmldoc's .ebuild maintainer for hints about configure's
+# workaround, and for a patch to fix CVE-2009-3050.
PRGNAM=htmldoc
VERSION=1.8.27
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
CWD=$(pwd)
@@ -48,14 +49,11 @@ elif [ "$ARCH" = "x86_64" ]; then
LIBDIRSUFFIX="64"
fi
-# Exit on most errors
-set -e
-
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xjf $CWD/$PRGNAM-$VERSION-source.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION-source.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
@@ -81,14 +79,14 @@ CXXFLAGS="$SLKCFLAGS" \
sed -i 's|\$(datadir)/doc/htmldoc|\$(prefix)/doc/htmldoc-1.8.27|g' \
doc/Makefile
-make all
+# Apply patch to fix several insecure calls to sscanf().
+# It's intended to resolve CVE-2009-3050 vulnerability.
+patch -p0 < $CWD/insecure_sscanf_patch.diff
+
+make all || exit 1
+
# DESTDIR= is not supported
-make prefix=$PKG/usr install
-# Documentation
-cd doc
-make all
-make prefix=$PKG/usr install
-cd ..
+make prefix=$PKG/usr install || exit 1
# Copy some files who are not automatically installed (main binary, .desktop, icons, etc..)
mkdir -p $PKG/usr/bin
@@ -111,8 +109,10 @@ cp -a desktop/htmldoc-96.png $PKG/usr/share/icons/hicolor/96x96/apps/$PRGNAM.png
cp -a desktop/htmldoc-128.png $PKG/usr/share/icons/hicolor/128x128/apps/$PRGNAM.png
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
( cd $PKG/usr/man
@@ -131,4 +131,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}