summaryrefslogtreecommitdiffstats
path: root/office/htmldoc
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2010-05-12 23:33:01 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:33:01 +0200
commit275dc9b95ba3e915c504f6e7fa11e5915bad2d22 (patch)
treebfa0fe54f0555caf03102d91613e126113b5a999 /office/htmldoc
parent83f437d12a6c1ce47ff0831dc1ab50f814556b4b (diff)
downloadslackbuilds-275dc9b95ba3e915c504f6e7fa11e5915bad2d22.tar.gz
slackbuilds-275dc9b95ba3e915c504f6e7fa11e5915bad2d22.tar.xz
office/htmldoc: Added to 12.2 repository
Diffstat (limited to 'office/htmldoc')
-rw-r--r--office/htmldoc/README11
-rw-r--r--office/htmldoc/doinst.sh14
-rw-r--r--office/htmldoc/htmldoc.SlackBuild134
-rw-r--r--office/htmldoc/htmldoc.info8
-rw-r--r--office/htmldoc/slack-desc19
5 files changed, 186 insertions, 0 deletions
diff --git a/office/htmldoc/README b/office/htmldoc/README
new file mode 100644
index 0000000000..502c7d31f4
--- /dev/null
+++ b/office/htmldoc/README
@@ -0,0 +1,11 @@
+HTMLDOC converts Hyper-Text Markup Language ("HTML") input files into
+indexed HTML, Adobe(r) PostScript(r), or Adobe(r) Portable Document
+Format ("PDF") files.
+HTMLDOC supports most HTML 3.2 elements, some HTML 4.0 elements, and
+can generate title and table of contents pages. The 1.8.x releases
+do not support stylesheets.
+HTMLDOC can be used as a standalone application, in a batch document
+processing environment, or as a web-based report generation application.
+No restrictions are placed upon the output produced by HTMLDOC.
+
+htmldoc requires fltk (available on SlackBuilds.org).
diff --git a/office/htmldoc/doinst.sh b/office/htmldoc/doinst.sh
new file mode 100644
index 0000000000..2a77b3fa85
--- /dev/null
+++ b/office/htmldoc/doinst.sh
@@ -0,0 +1,14 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
diff --git a/office/htmldoc/htmldoc.SlackBuild b/office/htmldoc/htmldoc.SlackBuild
new file mode 100644
index 0000000000..092643cf79
--- /dev/null
+++ b/office/htmldoc/htmldoc.SlackBuild
@@ -0,0 +1,134 @@
+#!/bin/sh
+
+# Slackware build script for htmldoc
+
+# Copyright 2009 LukenShiro <lukenshiro@ngi.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Thanks to Gentoo htmldoc's .ebuild maintainer for hints about configure's workaround
+
+PRGNAM=htmldoc
+VERSION=1.8.27
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="CHANGES.txt README.txt COMPILE.txt COPYING.txt htmldoc.eula htmldoc.readme"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+# Exit on most errors
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xjf $CWD/$PRGNAM-$VERSION-source.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# workaround to avoid /usr/share/doc/htmldoc's use for help function
+sed -i 's|^#define DOCUMENTATION "$prefix/share/doc/htmldoc"|\
+ #define DOCUMENTATION "$prefix/doc/htmldoc-1.8.27"|g' ./configure
+
+# --mandir seems to be ignored; --docdir doesn't exist
+# internal jpeg/png/zlib libs disabled (using system ones)
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --enable-ssl \
+ --with-gui \
+ --disable-localjpeg \
+ --disable-localzlib \
+ --disable-localpng
+
+# workaround to avoid /usr/share/doc/htmldoc's use for doc installation
+sed -i 's|\$(datadir)/doc/htmldoc|\$(prefix)/doc/htmldoc-1.8.27|g' \
+ doc/Makefile
+
+make all
+# DESTDIR= is not supported
+make prefix=$PKG/usr install
+# Documentation
+cd doc
+make all
+make prefix=$PKG/usr install
+cd ..
+
+# Copy some files who are not automatically installed (main binary, .desktop, icons, etc..)
+mkdir -p $PKG/usr/bin
+install -m 755 htmldoc/$PRGNAM $PKG/usr/bin
+mkdir -p $PKG/usr/man/man1
+cp -a doc/$PRGNAM.1 $PKG/usr/man/man1
+mkdir -p $PKG/usr/share/applications
+cp -a desktop/$PRGNAM.desktop $PKG/usr/share/applications
+mkdir -p $PKG/usr/share/mimelnk/application
+cp -a desktop/vnd.htmldoc-book.desktop $PKG/usr/share/mimelnk/application
+mkdir -p $PKG/usr/share/mime/packages
+cp -a desktop/htmldoc.xml $PKG/usr/share/mime/packages
+mkdir -p $PKG/usr/share/icons/hicolor/{16x16,24x24,32x32,48x48,64x64,96x96,128x128}/apps/
+cp -a desktop/htmldoc-16.png $PKG/usr/share/icons/hicolor/16x16/apps/$PRGNAM.png
+cp -a desktop/htmldoc-24.png $PKG/usr/share/icons/hicolor/24x24/apps/$PRGNAM.png
+cp -a desktop/htmldoc-32.png $PKG/usr/share/icons/hicolor/32x32/apps/$PRGNAM.png
+cp -a desktop/htmldoc-48.png $PKG/usr/share/icons/hicolor/48x48/apps/$PRGNAM.png
+cp -a desktop/htmldoc-64.png $PKG/usr/share/icons/hicolor/64x64/apps/$PRGNAM.png
+cp -a desktop/htmldoc-96.png $PKG/usr/share/icons/hicolor/96x96/apps/$PRGNAM.png
+cp -a desktop/htmldoc-128.png $PKG/usr/share/icons/hicolor/128x128/apps/$PRGNAM.png
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
+)
+
+# Just in case ..
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/office/htmldoc/htmldoc.info b/office/htmldoc/htmldoc.info
new file mode 100644
index 0000000000..a5a9baf698
--- /dev/null
+++ b/office/htmldoc/htmldoc.info
@@ -0,0 +1,8 @@
+PRGNAM="htmldoc"
+VERSION="1.8.27"
+HOMEPAGE="http://www.htmldoc.org/index.php"
+DOWNLOAD="http://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/htmldoc/1.8.27/htmldoc-1.8.27-source.tar.bz2"
+MD5SUM="35589e7b8fe9c54e11be87cd5aec4dcc"
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
+APPROVED="dsomero"
diff --git a/office/htmldoc/slack-desc b/office/htmldoc/slack-desc
new file mode 100644
index 0000000000..f12a4d19d3
--- /dev/null
+++ b/office/htmldoc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+htmldoc: htmldoc (an HTML to indexed HTML, ps and pdf conversion tool)
+htmldoc:
+htmldoc: It converts Hyper-Text Markup Language ("HTML") input files into
+htmldoc: indexed HTML, Adobe(r) PostScript(r), or Adobe(r) Portable Document
+htmldoc: Format ("PDF") files.
+htmldoc: It is a product by Easy Software Products.
+htmldoc:
+htmldoc: Homepage: http://www.htmldoc.org/index.php
+htmldoc:
+htmldoc:
+htmldoc: