summaryrefslogtreecommitdiffstats
path: root/office/kbbi-qt
diff options
context:
space:
mode:
author Ali Ahmadi <idnux09@gmail.com>2017-05-08 16:01:56 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-05-13 06:59:14 +0700
commit895d7d2b4a9f9ffa30c7b48693539b30da9e7149 (patch)
tree94c1f54375b561a80c6936af8d21b4a4399fc29a /office/kbbi-qt
parentffc501b9bf612f5582ba01565a925378f212bd1d (diff)
downloadslackbuilds-895d7d2b4a9f9ffa30c7b48693539b30da9e7149.tar.gz
slackbuilds-895d7d2b4a9f9ffa30c7b48693539b30da9e7149.tar.xz
office/kbbi-qt: Added (Indonesian Language Dictionary).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office/kbbi-qt')
-rw-r--r--office/kbbi-qt/README1
-rw-r--r--office/kbbi-qt/doinst.sh3
-rw-r--r--office/kbbi-qt/kbbi-qt.SlackBuild92
-rw-r--r--office/kbbi-qt/kbbi-qt.info10
-rw-r--r--office/kbbi-qt/slack-desc19
5 files changed, 125 insertions, 0 deletions
diff --git a/office/kbbi-qt/README b/office/kbbi-qt/README
new file mode 100644
index 0000000000..a0b23b7f7c
--- /dev/null
+++ b/office/kbbi-qt/README
@@ -0,0 +1 @@
+KBBI Qt is GUI-based Indonesian Language Dictionary.
diff --git a/office/kbbi-qt/doinst.sh b/office/kbbi-qt/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/office/kbbi-qt/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/office/kbbi-qt/kbbi-qt.SlackBuild b/office/kbbi-qt/kbbi-qt.SlackBuild
new file mode 100644
index 0000000000..26298ed0ec
--- /dev/null
+++ b/office/kbbi-qt/kbbi-qt.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for kbbi-qt
+
+# Copyright 2017 Ali Ahmadi <idnux09@gmail.com>
+# # All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Based on the Arch PKGBUILD
+
+PRGNAM=kbbi-qt
+VERSION=${VERSION:-1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+
+tar xvf $CWD/$PRGNAM-${VERSION}.tar.gz
+cd $PRGNAM-$VERSION
+
+qmake-qt5 KBBI-Qt.pro
+make
+
+mkdir -p $PKG/usr/bin
+install -m755 KBBI-Qt $PKG/usr/bin
+
+mkdir -p $PKG/usr/share/KBBI-Qt
+cp -R src/data $PKG/usr/share/KBBI-Qt
+
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+install -m644 KBBI-Qt.desktop $PKG/usr/share/applications/
+cp src/kbbi-qt.png $PKG/usr/share/pixmaps
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+install -m644 README.md $PKG/usr/doc/$PRGNAM-$VERSION/README
+install -m644 LICENSE $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/kbbi-qt/kbbi-qt.info b/office/kbbi-qt/kbbi-qt.info
new file mode 100644
index 0000000000..a63e53096a
--- /dev/null
+++ b/office/kbbi-qt/kbbi-qt.info
@@ -0,0 +1,10 @@
+PRGNAM="kbbi-qt"
+VERSION="1.1"
+HOMEPAGE="https://github.com/bgli/kbbi-qt/"
+DOWNLOAD="https://github.com/bgli/kbbi-qt/archive/v1.1/kbbi-qt-1.1.tar.gz"
+MD5SUM="e615b9fb1ee5bea9ab2b49beebd9c6c6"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="qt5"
+MAINTAINER="Ali Ahmadi"
+EMAIL="idnux09@gmail.com"
diff --git a/office/kbbi-qt/slack-desc b/office/kbbi-qt/slack-desc
new file mode 100644
index 0000000000..68a40bcfd7
--- /dev/null
+++ b/office/kbbi-qt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+kbbi-qt: kbbi-qt (Indonesian Language Dictionary)
+kbbi-qt:
+kbbi-qt: GUI-based Indonesian Language Dictionary
+kbbi-qt:
+kbbi-qt:
+kbbi-qt:
+kbbi-qt:
+kbbi-qt:
+kbbi-qt:
+kbbi-qt:
+kbbi-qt: