summaryrefslogtreecommitdiffstats
path: root/perl/perl-Test-TempDir-Tiny
diff options
context:
space:
mode:
author Andreas Guldstrand <andreas.guldstrand@gmail.com>2018-09-14 08:33:52 +0100
committer David Spencer <idlemoor@slackbuilds.org>2018-09-14 08:33:52 +0100
commit082491efb9f170a38b21c3d12c1f7d304d8b8676 (patch)
treee0deeb9ed1f22ce2d48d8e912f75b44207b7668f /perl/perl-Test-TempDir-Tiny
parent25ef34e9fdb3d20cea7e07cd0fafcc34c2034494 (diff)
downloadslackbuilds-082491efb9f170a38b21c3d12c1f7d304d8b8676.tar.gz
slackbuilds-082491efb9f170a38b21c3d12c1f7d304d8b8676.tar.xz
perl/perl-Test-TempDir-Tiny: Added (keep temp dirs if tests fail).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'perl/perl-Test-TempDir-Tiny')
-rw-r--r--perl/perl-Test-TempDir-Tiny/README5
-rw-r--r--perl/perl-Test-TempDir-Tiny/perl-Test-TempDir-Tiny.SlackBuild102
-rw-r--r--perl/perl-Test-TempDir-Tiny/perl-Test-TempDir-Tiny.info10
-rw-r--r--perl/perl-Test-TempDir-Tiny/slack-desc19
-rw-r--r--perl/perl-Test-TempDir-Tiny/version-requirements.patch52
5 files changed, 188 insertions, 0 deletions
diff --git a/perl/perl-Test-TempDir-Tiny/README b/perl/perl-Test-TempDir-Tiny/README
new file mode 100644
index 0000000000..9e78ae3838
--- /dev/null
+++ b/perl/perl-Test-TempDir-Tiny/README
@@ -0,0 +1,5 @@
+This module works with Test::More to create temporary directories that
+stick around if tests fail.
+
+It is loosely based on Test::TempDir, but with less complexity, greater
+portability and zero non-core dependencies.
diff --git a/perl/perl-Test-TempDir-Tiny/perl-Test-TempDir-Tiny.SlackBuild b/perl/perl-Test-TempDir-Tiny/perl-Test-TempDir-Tiny.SlackBuild
new file mode 100644
index 0000000000..03dfed9860
--- /dev/null
+++ b/perl/perl-Test-TempDir-Tiny/perl-Test-TempDir-Tiny.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/sh
+
+# Slackware build script for perl-Test-TempDir-Tiny
+
+# Copyright 2018 Andreas Guldstrand
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=perl-Test-TempDir-Tiny
+VERSION=${VERSION:-0.018}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/version-requirements.patch
+
+perl Makefile.PL \
+ PREFIX=/usr \
+ INSTALLDIRS=vendor \
+ INSTALLVENDORMAN1DIR=/usr/man/man1 \
+ INSTALLVENDORMAN3DIR=/usr/man/man3
+make
+make test
+make install DESTDIR=$PKG
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
+
+find $PKG -depth -type d -empty -delete || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ Changes CONTRIBUTING.mkdn LICENSE README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/perl/perl-Test-TempDir-Tiny/perl-Test-TempDir-Tiny.info b/perl/perl-Test-TempDir-Tiny/perl-Test-TempDir-Tiny.info
new file mode 100644
index 0000000000..7f26a3ecf7
--- /dev/null
+++ b/perl/perl-Test-TempDir-Tiny/perl-Test-TempDir-Tiny.info
@@ -0,0 +1,10 @@
+PRGNAM="perl-Test-TempDir-Tiny"
+VERSION="0.018"
+HOMEPAGE="https://metacpan.org/pod/Test::TempDir::Tiny"
+DOWNLOAD="https://cpan.metacpan.org/authors/id/D/DA/DAGOLDEN/Test-TempDir-Tiny-0.018.tar.gz"
+MD5SUM="9f2bfba5df172dbe1a28cad360b9fea5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Andreas Guldstrand"
+EMAIL="andreas.guldstrand@gmail.com"
diff --git a/perl/perl-Test-TempDir-Tiny/slack-desc b/perl/perl-Test-TempDir-Tiny/slack-desc
new file mode 100644
index 0000000000..64c625c4d2
--- /dev/null
+++ b/perl/perl-Test-TempDir-Tiny/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+perl-Test-TempDir-Tiny: perl-Test-TempDir-Tiny (temp dirs that stick around if tests fail)
+perl-Test-TempDir-Tiny:
+perl-Test-TempDir-Tiny: This module works with Test::More to create temporary directories
+perl-Test-TempDir-Tiny: that stick around if tests fail.
+perl-Test-TempDir-Tiny:
+perl-Test-TempDir-Tiny: It is loosely based on Test::TempDir, but with less complexity,
+perl-Test-TempDir-Tiny: greater portability and zero non-core dependencies.
+perl-Test-TempDir-Tiny:
+perl-Test-TempDir-Tiny:
+perl-Test-TempDir-Tiny:
+perl-Test-TempDir-Tiny:
diff --git a/perl/perl-Test-TempDir-Tiny/version-requirements.patch b/perl/perl-Test-TempDir-Tiny/version-requirements.patch
new file mode 100644
index 0000000000..22a5e929bd
--- /dev/null
+++ b/perl/perl-Test-TempDir-Tiny/version-requirements.patch
@@ -0,0 +1,52 @@
+diff -ru a/lib/Test/TempDir/Tiny.pm b/lib/Test/TempDir/Tiny.pm
+--- a/lib/Test/TempDir/Tiny.pm 2018-07-12 14:22:03.000000000 +0200
++++ b/lib/Test/TempDir/Tiny.pm 2018-09-13 21:05:04.417528503 +0200
+@@ -18,7 +18,7 @@
+ use File::Path 2.07 qw/remove_tree/;
+ }
+ use File::Spec::Functions qw/catdir/;
+-use File::Temp 0.2308;
++use File::Temp 0.2304;
+
+ my ( $ROOT_DIR, $TEST_DIR, %COUNTER );
+ my ( $ORIGINAL_PID, $ORIGINAL_CWD, $TRIES, $DELAY, $SYSTEM_TEMP ) =
+diff -ru a/Makefile.PL b/Makefile.PL
+--- a/Makefile.PL 2018-07-12 14:22:03.000000000 +0200
++++ b/Makefile.PL 2018-09-13 21:04:51.652738922 +0200
+@@ -23,7 +23,7 @@
+ "Exporter" => "5.57",
+ "File::Path" => "2.07",
+ "File::Spec::Functions" => 0,
+- "File::Temp" => "0.2308",
++ "File::Temp" => "0.2304",
+ "strict" => 0,
+ "warnings" => 0
+ },
+@@ -50,7 +50,7 @@
+ "File::Path" => "2.07",
+ "File::Spec" => 0,
+ "File::Spec::Functions" => 0,
+- "File::Temp" => "0.2308",
++ "File::Temp" => "0.2304",
+ "Test::More" => 0,
+ "strict" => 0,
+ "warnings" => 0
+diff -ru a/t/00-report-prereqs.dd b/t/00-report-prereqs.dd
+--- a/t/00-report-prereqs.dd 2018-07-12 14:22:03.000000000 +0200
++++ b/t/00-report-prereqs.dd 2018-09-13 21:05:27.798806480 +0200
+@@ -37,7 +37,7 @@
+ 'Exporter' => '5.57',
+ 'File::Path' => '2.07',
+ 'File::Spec::Functions' => '0',
+- 'File::Temp' => '0.2308',
++ 'File::Temp' => '0.2304',
+ 'perl' => '5.006002',
+ 'strict' => '0',
+ 'warnings' => '0'
+@@ -58,4 +58,4 @@
+ }
+ };
+ $x;
+- }
+\ No newline at end of file
++ }