summaryrefslogtreecommitdiffstats
path: root/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-21 21:32:05 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-06-02 01:02:21 +0700
commita33f35bc154e48389ab6cea5077a60a730290ae2 (patch)
tree19def0550cb6885d6be2201da815328ee8591c52 /python/BeautifulSoup4/BeautifulSoup4.SlackBuild
parent633150fbbd18773852d2552c9065eb1d12a69b91 (diff)
downloadslackbuilds-a33f35bc154e48389ab6cea5077a60a730290ae2.tar.gz
slackbuilds-a33f35bc154e48389ab6cea5077a60a730290ae2.tar.xz
python/BeautifulSoup4: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/BeautifulSoup4/BeautifulSoup4.SlackBuild')
-rw-r--r--python/BeautifulSoup4/BeautifulSoup4.SlackBuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/python/BeautifulSoup4/BeautifulSoup4.SlackBuild b/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
index 6793e1369a..ff38ba2659 100644
--- a/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
+++ b/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
@@ -72,10 +72,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Python 2 support (requires python-soupsieve)
-if $(python2 -c 'import soupsieve' 2>/dev/null); then
- python setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
# Python 3 support (requires python3-soupsieve)
# shaypal5 provided an example package check:
@@ -94,7 +91,7 @@ if $(python3 -c 'import pkgutil; exit(not pkgutil.find_loader("soupsieve"))'); t
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- # Build for Python 3
+ # Build for Python 3
sed -i "s/-rfI/-rf/" convert-py3k
sh convert-py3k
python3 setup.py install --root=$PKG