summaryrefslogtreecommitdiffstats
path: root/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2021-02-12 20:04:12 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-02-14 06:27:52 +0700
commitd5e006947cc8002afc1c42dfbedd3b7742bdd538 (patch)
tree37ac6de4cc61eace7d6ae6fcaf146bcc33bf84b9 /python/BeautifulSoup4/BeautifulSoup4.SlackBuild
parent2fe5e8fa3b86fc16fd8b9670ba2e9755df1d4e59 (diff)
downloadslackbuilds-d5e006947cc8002afc1c42dfbedd3b7742bdd538.tar.gz
slackbuilds-d5e006947cc8002afc1c42dfbedd3b7742bdd538.tar.xz
python/BeautifulSoup4: Fix python3 build.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/BeautifulSoup4/BeautifulSoup4.SlackBuild')
-rw-r--r--python/BeautifulSoup4/BeautifulSoup4.SlackBuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/python/BeautifulSoup4/BeautifulSoup4.SlackBuild b/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
index 1c370f2fcd..6793e1369a 100644
--- a/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
+++ b/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for BeautifulSoup4
# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
-# Copyright 2020 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2020-2021 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
PRGNAM=BeautifulSoup4
VERSION=${VERSION:-4.9.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
SRCNAM=beautifulsoup4
@@ -72,12 +72,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Python 2 support (requires python-soupsieve)
if $(python2 -c 'import soupsieve' 2>/dev/null); then
python setup.py install --root=$PKG
fi
# Python 3 support (requires python3-soupsieve)
-if $(python3 -c 'import soupsieve' 2>/dev/null); then
+# shaypal5 provided an example package check:
+# https://gist.github.com/shaypal5/d505af9953cd86f59c750fa600ee4ba6
+if $(python3 -c 'import pkgutil; exit(not pkgutil.find_loader("soupsieve"))'); then
+
+ # Prepare another source tarball before building for Python 3
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
@@ -88,6 +93,8 @@ if $(python3 -c 'import soupsieve' 2>/dev/null); then
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+ # Build for Python 3
sed -i "s/-rfI/-rf/" convert-py3k
sh convert-py3k
python3 setup.py install --root=$PKG