summaryrefslogtreecommitdiffstats
path: root/python/PyRIC
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2017-06-05 21:05:59 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-06-06 07:56:18 +0700
commitf591f2e322a51f8622c7abd323e17879c42cd5ee (patch)
tree4eb60f8a683909237b6a41ee66a7e9b69c2b8e38 /python/PyRIC
parent5a01946ed94bba0bf8a3d795eeaf227af818ebbb (diff)
downloadslackbuilds-f591f2e322a51f8622c7abd323e17879c42cd5ee.tar.gz
slackbuilds-f591f2e322a51f8622c7abd323e17879c42cd5ee.tar.xz
python/PyRIC: Added (Linux wireless library for Python).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/PyRIC')
-rw-r--r--python/PyRIC/PyRIC.SlackBuild85
-rw-r--r--python/PyRIC/PyRIC.info10
-rw-r--r--python/PyRIC/README32
-rw-r--r--python/PyRIC/slack-desc19
4 files changed, 146 insertions, 0 deletions
diff --git a/python/PyRIC/PyRIC.SlackBuild b/python/PyRIC/PyRIC.SlackBuild
new file mode 100644
index 0000000000..b72475433b
--- /dev/null
+++ b/python/PyRIC/PyRIC.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for PyRIC
+
+# Copyright 2017 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=PyRIC
+VERSION=${VERSION:-0.1.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md LICENSE CHANGES TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/PyRIC/PyRIC.info b/python/PyRIC/PyRIC.info
new file mode 100644
index 0000000000..fb7ee7a7ab
--- /dev/null
+++ b/python/PyRIC/PyRIC.info
@@ -0,0 +1,10 @@
+PRGNAM="PyRIC"
+VERSION="0.1.6"
+HOMEPAGE="http://wraith-wireless.github.io/PyRIC/"
+DOWNLOAD="https://github.com/wraith-wireless/PyRIC/archive/0.1.6/PyRIC-0.1.6.tar.gz"
+MD5SUM="f00e3ee67a57a9bd24d8aa0ed8577957"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/PyRIC/README b/python/PyRIC/README
new file mode 100644
index 0000000000..175cb91527
--- /dev/null
+++ b/python/PyRIC/README
@@ -0,0 +1,32 @@
+PyRIC (is a Linux only) library providing wireless developers and
+pentesters the ability to identify, enumerate and manipulate their
+system's wireless cards programmatically in Python. Pentesting
+applications and scripts written in Python have increased dramatically
+in recent years. However, these tools still rely on Linux command lines
+tools to setup and prepare and restore the system for use. Until now.
+Why use subprocess.Popen, regular expressions and str.find to interact
+with your wireless cards? PyRIC is:
+
+ * Pythonic: no ctypes, SWIG etc. PyRIC redefines C header files as
+ Python and uses sockets to communicate with the kernel.
+
+ * Self-sufficient: No third-party files used. PyRIC is completely
+ self-contained.
+
+ * Fast: (relatively speaking) PyRIC is faster than using command line
+ tools through subprocess.Popen
+
+ * Parseless: Get the output you want without parsing output from
+ command line tools. Never worry about newer iw versions and having
+ to rewrite your parsers.
+
+ * Easy: If you can use iw, you can use PyRIC.
+
+At its heart, PyRIC is a Python port of (a subset of) iw and by
+extension, a Python port of Netlink w.r.t nl80211 functionality. The
+original goal of PyRIC was to provide a simple interface to the
+underlying nl80211 kernel support, handling the complex operations of
+Netlink seamlessly while maintaining a minimum of "code walking" to
+understand, modify and extend. But, why stop there? Since its initial
+inception, PyRIC has grown. PyRIC puts iw, ifconfig, rfkill, udevadm,
+airmon-ng and macchanger in your hands (or your program).
diff --git a/python/PyRIC/slack-desc b/python/PyRIC/slack-desc
new file mode 100644
index 0000000000..e6e71b197d
--- /dev/null
+++ b/python/PyRIC/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+PyRIC: PyRIC (Linux wireless library for Python)
+PyRIC:
+PyRIC: PyRIC (is a Linux only) library providing wireless developers and
+PyRIC: pentesters the ability to identify, enumerate and manipulate their
+PyRIC: system's wireless cards programmatically in Python. Pentesting
+PyRIC: applications and scripts written in Python have increased
+PyRIC: dramatically in recent years. However, these tools still rely on
+PyRIC: Linux command lines tools to setup and prepare and restore the
+PyRIC: system for use.
+PyRIC:
+PyRIC: Homepage: http://wraith-wireless.github.io/PyRIC/