summaryrefslogtreecommitdiffstats
path: root/python/Routes
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-21 21:32:08 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-06-02 01:02:22 +0700
commitf6bc0ae1a332f8a9ceac21ed12e187e5785b2503 (patch)
tree24c53e91ea456b9ac1c6fcd75a1712f832e884be /python/Routes
parent8a5bc0522efa4c23584748b06ce30aa51471b028 (diff)
downloadslackbuilds-f6bc0ae1a332f8a9ceac21ed12e187e5785b2503.tar.gz
slackbuilds-f6bc0ae1a332f8a9ceac21ed12e187e5785b2503.tar.xz
python/Routes: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/Routes')
-rw-r--r--python/Routes/README11
-rw-r--r--python/Routes/Routes.SlackBuild6
2 files changed, 8 insertions, 9 deletions
diff --git a/python/Routes/README b/python/Routes/README
index 89c29985db..19ea690829 100644
--- a/python/Routes/README
+++ b/python/Routes/README
@@ -1,8 +1,9 @@
-Routes is a Python re-implementation of the Rails routes system for mapping URLs
-to application actions, and conversely to generate URLs.
-Routes makes it easy to create pretty and concise URLs that are RESTful with little effort.
+Routes is a Python re-implementation of the Rails routes system for
+mapping URLs to application actions, and conversely to generate URLs.
+Routes makes it easy to create pretty and concise URLs that are RESTful
+with little effort.
-Routes allows conditional matching based on domain, cookies, HTTP method,
-or a custom function.
+Routes allows conditional matching based on domain, cookies, HTTP
+method, or a custom function.
Sub-domain support is built in.
Routes comes with an extensive unit test suite.
diff --git a/python/Routes/Routes.SlackBuild b/python/Routes/Routes.SlackBuild
index 8ace01d8e1..d9374ad217 100644
--- a/python/Routes/Routes.SlackBuild
+++ b/python/Routes/Routes.SlackBuild
@@ -53,10 +53,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.rst MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION