summaryrefslogtreecommitdiffstats
path: root/python/alabaster
diff options
context:
space:
mode:
author Nikos Giotis <nikos.giotis@gmail.com>2017-03-05 09:45:43 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-03-05 09:45:43 +0700
commit61c859192f1d7af38a6c0cd53d8bba0c2e6e7302 (patch)
tree95d2be1289201a5ac6a80acef2293052841c7d0c /python/alabaster
parentf8cb5330cb6bf36ba168a9d61900dccb358b2c70 (diff)
downloadslackbuilds-61c859192f1d7af38a6c0cd53d8bba0c2e6e7302.tar.gz
slackbuilds-61c859192f1d7af38a6c0cd53d8bba0c2e6e7302.tar.xz
python/alabaster: Added (Sphinx theme).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/alabaster')
-rw-r--r--python/alabaster/README13
-rw-r--r--python/alabaster/alabaster.SlackBuild85
-rw-r--r--python/alabaster/alabaster.info10
-rw-r--r--python/alabaster/slack-desc19
4 files changed, 127 insertions, 0 deletions
diff --git a/python/alabaster/README b/python/alabaster/README
new file mode 100644
index 0000000000..23f045aae5
--- /dev/null
+++ b/python/alabaster/README
@@ -0,0 +1,13 @@
+A configurable sidebar-enabled Sphinx theme
+
+Alabaster is a visually (c)lean, responsive, configurable theme
+for the Sphinx documentation system. It is Python 2+3 compatible.
+
+It began as a third-party theme, and is still maintained separately,
+but as of Sphinx 1.3, Alabaster is an install-time dependency
+of Sphinx and is selected as the default theme.
+
+Live examples of this theme can be seen on this project’s own
+website, paramiko.org, fabfile.org and pyinvoke.org.
+
+For more documentation, please see http://alabaster.readthedocs.io.
diff --git a/python/alabaster/alabaster.SlackBuild b/python/alabaster/alabaster.SlackBuild
new file mode 100644
index 0000000000..e06452d839
--- /dev/null
+++ b/python/alabaster/alabaster.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for alabaster
+
+# Copyright 2017 Nikos Giotis <nikos.giotis@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=alabaster
+VERSION=${VERSION:-0.7.9}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/alabaster/alabaster.info b/python/alabaster/alabaster.info
new file mode 100644
index 0000000000..e150d302d6
--- /dev/null
+++ b/python/alabaster/alabaster.info
@@ -0,0 +1,10 @@
+PRGNAM="alabaster"
+VERSION="0.7.9"
+HOMEPAGE="https://alabaster.readthedocs.io/"
+DOWNLOAD="https://pypi.python.org/packages/71/c3/70da7d8ac18a4f4c502887bd2549e05745fa403e2cd9d06a8a9910a762bc/alabaster-0.7.9.tar.gz"
+MD5SUM="b29646a8bbe7aa52830375b7d17b5d7a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Nikos Giotis"
+EMAIL="nikos.giotis@gmail.com"
diff --git a/python/alabaster/slack-desc b/python/alabaster/slack-desc
new file mode 100644
index 0000000000..ac64dcfad2
--- /dev/null
+++ b/python/alabaster/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+alabaster: alabaster (A configurable sidebar-enabled Sphinx theme)
+alabaster:
+alabaster: Alabaster is a visually (c)lean, responsive, configurable theme for
+alabaster: the Sphinx documentation system. It is Python 2+3 compatible.
+alabaster:
+alabaster: https://alabaster.readthedocs.io/
+alabaster:
+alabaster:
+alabaster:
+alabaster:
+alabaster: