summaryrefslogtreecommitdiffstats
path: root/python/asn1crypto
diff options
context:
space:
mode:
author Markus Reichelt <slackbuilds@mareichelt.de>2017-03-11 23:22:14 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-03-18 06:58:11 +0700
commita84281b22d951dc88070fc16584046fae084a999 (patch)
tree306f6f69d7aa7933e18eecf3229c83aaff5f85fa /python/asn1crypto
parenta9715f7d8a838edd3edb6eb5333a571267c812c7 (diff)
downloadslackbuilds-a84281b22d951dc88070fc16584046fae084a999.tar.gz
slackbuilds-a84281b22d951dc88070fc16584046fae084a999.tar.xz
python/asn1crypto: Added (Fast ASN.1 parser and serializer).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/asn1crypto')
-rw-r--r--python/asn1crypto/README3
-rw-r--r--python/asn1crypto/asn1crypto.SlackBuild85
-rw-r--r--python/asn1crypto/asn1crypto.info10
-rw-r--r--python/asn1crypto/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/asn1crypto/README b/python/asn1crypto/README
new file mode 100644
index 0000000000..2093f7fe94
--- /dev/null
+++ b/python/asn1crypto/README
@@ -0,0 +1,3 @@
+Fast ASN.1 parser and serializer with definitions for private keys,
+public keys, certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7, PKCS#8,
+PKCS#12, PKCS#5, X.509 and TSPB.
diff --git a/python/asn1crypto/asn1crypto.SlackBuild b/python/asn1crypto/asn1crypto.SlackBuild
new file mode 100644
index 0000000000..2e99eb5bfa
--- /dev/null
+++ b/python/asn1crypto/asn1crypto.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for asn1crypto
+#
+# Copyright 2017 Markus Reichelt, Aachen, DE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=asn1crypto
+VERSION=${VERSION:-0.21.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/asn1crypto/asn1crypto.info b/python/asn1crypto/asn1crypto.info
new file mode 100644
index 0000000000..0977bffb24
--- /dev/null
+++ b/python/asn1crypto/asn1crypto.info
@@ -0,0 +1,10 @@
+PRGNAM="asn1crypto"
+VERSION="0.21.1"
+HOMEPAGE="https://pypi.python.org/pypi/asn1crypto"
+DOWNLOAD="https://pypi.python.org/packages/ce/39/17e90c2efacc4060915f7d1f9b8d2a5b20e54e46233bdf3092e68193407d/asn1crypto-0.21.1.tar.gz"
+MD5SUM="d8e311a39136229c53f4ed83dcfaf624"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Markus Reichelt"
+EMAIL="slackbuilds@mareichelt.de"
diff --git a/python/asn1crypto/slack-desc b/python/asn1crypto/slack-desc
new file mode 100644
index 0000000000..6a6e7aa34f
--- /dev/null
+++ b/python/asn1crypto/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+asn1crypto: asn1crypto (Fast ASN.1 parser and serializer)
+asn1crypto:
+asn1crypto: https://pypi.python.org/pypi/asn1crypto
+asn1crypto:
+asn1crypto:
+asn1crypto:
+asn1crypto:
+asn1crypto:
+asn1crypto:
+asn1crypto:
+asn1crypto: