summaryrefslogtreecommitdiffstats
path: root/python/bsddb3
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2021-04-19 22:07:41 -0500
committer Robby Workman <rworkman@slackbuilds.org>2021-04-19 22:07:41 -0500
commit2e72e2eac9b105cb0b7e0aaa1b68eeffc3575c4b (patch)
tree1f20099e3805df0b47f54e48de721847fb4121f1 /python/bsddb3
parentef7716f86daa446d9bcac3167e6e03c36a74c4b3 (diff)
downloadslackbuilds-2e72e2eac9b105cb0b7e0aaa1b68eeffc3575c4b.tar.gz
slackbuilds-2e72e2eac9b105cb0b7e0aaa1b68eeffc3575c4b.tar.xz
python/bsddb3: Build with python3 unconditionally
Diffstat (limited to 'python/bsddb3')
-rw-r--r--python/bsddb3/README6
-rw-r--r--python/bsddb3/bsddb3.SlackBuild7
2 files changed, 2 insertions, 11 deletions
diff --git a/python/bsddb3/README b/python/bsddb3/README
index 1d63c26b04..0dd2394514 100644
--- a/python/bsddb3/README
+++ b/python/bsddb3/README
@@ -8,9 +8,3 @@ objects can use various access methods: btree, hash, recno, and
queue. Complete support of Berkeley DB distributed transactions.
Complete support for Berkeley DB Replication Manager. Complete
support for Berkeley DB Base Replication. Support for RPC.
-
-
-python3 is an optional dependency. You need to set PYTHON3=yes,
-for example:
-
- PYTHON3=yes ./bsddb3.SlackBuild
diff --git a/python/bsddb3/bsddb3.SlackBuild b/python/bsddb3/bsddb3.SlackBuild
index 06e12f59e6..144f1478d5 100644
--- a/python/bsddb3/bsddb3.SlackBuild
+++ b/python/bsddb3/bsddb3.SlackBuild
@@ -70,11 +70,8 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-
-if [ "${PYTHON3:-no}" = "yes" ]; then
- rm -rf build
- python3 setup.py install --root=$PKG
-fi
+rm -rf build
+python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true