summaryrefslogtreecommitdiffstats
path: root/python/ecdsa/ecdsa.SlackBuild
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-01-04 08:18:58 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-01-04 08:18:58 +0700
commita4e4e74313d7bac5a68340317f59c86dca8ee6b9 (patch)
treeafd66ae87de9118d616f70f8f8c5bc6d3f509934 /python/ecdsa/ecdsa.SlackBuild
parent4fa9eb84db445c775d33e696a3e8de24108d3263 (diff)
downloadslackbuilds-a4e4e74313d7bac5a68340317f59c86dca8ee6b9.tar.gz
slackbuilds-a4e4e74313d7bac5a68340317f59c86dca8ee6b9.tar.xz
python/ecdsa: Add python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/ecdsa/ecdsa.SlackBuild')
-rw-r--r--python/ecdsa/ecdsa.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/python/ecdsa/ecdsa.SlackBuild b/python/ecdsa/ecdsa.SlackBuild
index 40450aaa0d..46c7a8eeaa 100644
--- a/python/ecdsa/ecdsa.SlackBuild
+++ b/python/ecdsa/ecdsa.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ecdsa
-# Copyright 2013-2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2013-2018 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -71,6 +71,10 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true