summaryrefslogtreecommitdiffstats
path: root/python/jellyfish
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-11-07 17:12:05 +0200
committer David Spencer <idlemoor@slackbuilds.org>2016-11-11 20:36:30 +0000
commit8cbf4d5fb88826ea9865dce9e1eef19a0cdd8a40 (patch)
tree3449c7f7547c396b4e18d4dcd2159ed9d11fe256 /python/jellyfish
parentdc01ce54a39f2888da97a0016a95c9157197cdd7 (diff)
downloadslackbuilds-8cbf4d5fb88826ea9865dce9e1eef19a0cdd8a40.tar.gz
slackbuilds-8cbf4d5fb88826ea9865dce9e1eef19a0cdd8a40.tar.xz
python/jellyfish: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python/jellyfish')
-rw-r--r--python/jellyfish/jellyfish.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/python/jellyfish/jellyfish.SlackBuild b/python/jellyfish/jellyfish.SlackBuild
index aacd3524ad..a18b866e33 100644
--- a/python/jellyfish/jellyfish.SlackBuild
+++ b/python/jellyfish/jellyfish.SlackBuild
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -65,9 +65,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG