summaryrefslogtreecommitdiffstats
path: root/python/mypy
diff options
context:
space:
mode:
author Tim Dickson <dickson.tim@gmail.com>2018-11-02 22:19:12 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-11-03 07:46:44 +0700
commitaffa13c8b0242c96cb9a788b878dde3d13b27adf (patch)
treee202a72e86e4cdd8e0dd7e6e2f9b89a7a56afde2 /python/mypy
parent3a76793e3b104f4179a46ba21513f46071da097d (diff)
downloadslackbuilds-affa13c8b0242c96cb9a788b878dde3d13b27adf.tar.gz
slackbuilds-affa13c8b0242c96cb9a788b878dde3d13b27adf.tar.xz
python/mypy: Added (an optional static type checker for python).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/mypy')
-rw-r--r--python/mypy/README7
-rw-r--r--python/mypy/mypy.SlackBuild86
-rw-r--r--python/mypy/mypy.info10
-rw-r--r--python/mypy/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/python/mypy/README b/python/mypy/README
new file mode 100644
index 0000000000..585ec07be6
--- /dev/null
+++ b/python/mypy/README
@@ -0,0 +1,7 @@
+Mypy is an optional static type checker for Python. You can add type hints
+(PEP 484) to your Python programs, and use mypy to type check them
+statically. Find bugs in your programs without even running them!
+
+You can mix dynamic and static typing in your programs. You can always
+fall back to dynamic typing when static typing is not convenient, such
+as for legacy code.
diff --git a/python/mypy/mypy.SlackBuild b/python/mypy/mypy.SlackBuild
new file mode 100644
index 0000000000..e7222e8c5a
--- /dev/null
+++ b/python/mypy/mypy.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for mypy
+
+# Written by Tim Dickson dickson.tim@googlemail.com
+# Copyright (c) 2018 Tim Dickson, Scotland
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=mypy
+VERSION=${VERSION:-0.641}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/mypy/mypy.info b/python/mypy/mypy.info
new file mode 100644
index 0000000000..a3ae9f565a
--- /dev/null
+++ b/python/mypy/mypy.info
@@ -0,0 +1,10 @@
+PRGNAM="mypy"
+VERSION="0.641"
+HOMEPAGE="https://pypi.org/project/mypy"
+DOWNLOAD="https://files.pythonhosted.org/packages/a1/b9/e2063c8f933c1cfebef5dcd7325e07b927cf5a5cef60772aaad5eb903a0f/mypy-0.641.tar.gz"
+MD5SUM="0482206562efb299160a49f01221254f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="typed_ast"
+MAINTAINER="Tim Dickson"
+EMAIL="dickson.tim@gmail.com"
diff --git a/python/mypy/slack-desc b/python/mypy/slack-desc
new file mode 100644
index 0000000000..78abf24e44
--- /dev/null
+++ b/python/mypy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+mypy: mypy (an optional static type checker for python)
+mypy:
+mypy: Mypy is an optional static type checker for Python.
+mypy: You can add type hints (PEP 484) to your Python programs, and use
+mypy: mypy to type check them statically.
+mypy:
+mypy: Homepage: https://pypi.org/project/mypy
+mypy:
+mypy:
+mypy:
+mypy: