summaryrefslogtreecommitdiffstats
path: root/python/npm
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2023-05-15 21:52:48 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 11:17:38 +0700
commit616a7eaa0cf6037c2fcb690824960a2dfa30b9d7 (patch)
treef4bb0587b5d2e9c57273677e85cd23aa083d3816 /python/npm
parent1bb7b40fbcf2f9407a3bbd563b99072b0ee18c1e (diff)
downloadslackbuilds-616a7eaa0cf6037c2fcb690824960a2dfa30b9d7.tar.gz
slackbuilds-616a7eaa0cf6037c2fcb690824960a2dfa30b9d7.tar.xz
python/npm: Align with template.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/npm')
-rw-r--r--python/npm/npm.SlackBuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/python/npm/npm.SlackBuild b/python/npm/npm.SlackBuild
index b4d412ccd0..29ae80e9e4 100644
--- a/python/npm/npm.SlackBuild
+++ b/python/npm/npm.SlackBuild
@@ -41,15 +41,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -73,12 +70,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
- else
- python setup.py install --root=$PKG
-fi
+# Python 2.7 will be dropped in the future.
+python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG