summaryrefslogtreecommitdiffstats
path: root/python/pelican/pelican.SlackBuild
diff options
context:
space:
mode:
author Markus Reichelt <slackbuilds@mareichelt.de>2016-09-14 18:06:51 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-09-14 18:06:51 +0700
commita393114be9e4ecf10e83c9b91c74a082e3c8f9a6 (patch)
tree458b0136d5000d76e57d059dc965e520d49ef239 /python/pelican/pelican.SlackBuild
parentdf65f7ec3d47a955c5af6c6181eb064e69ac31bc (diff)
downloadslackbuilds-a393114be9e4ecf10e83c9b91c74a082e3c8f9a6.tar.gz
slackbuilds-a393114be9e4ecf10e83c9b91c74a082e3c8f9a6.tar.xz
python/pelican: Updated for version 3.6.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pelican/pelican.SlackBuild')
-rw-r--r--python/pelican/pelican.SlackBuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/python/pelican/pelican.SlackBuild b/python/pelican/pelican.SlackBuild
index 928628223d..57276f19d8 100644
--- a/python/pelican/pelican.SlackBuild
+++ b/python/pelican/pelican.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pelican
-# Copyright 2015 Markus Reichelt, Stolberg (Rhld.), DE
+# Copyright 2015-2016 Markus Reichelt, Aachen, DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,13 +24,13 @@
# Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
PRGNAM=pelican
-VERSION=${VERSION:-3.5.0}
+VERSION=${VERSION:-3.6.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -41,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -66,9 +66,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG