summaryrefslogtreecommitdiffstats
path: root/python/phply/phply.SlackBuild
diff options
context:
space:
mode:
author Brenton Earl <brent@exitstatusone.com>2018-11-02 12:18:57 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-11-03 07:46:40 +0700
commit514e76fd62ec642188bbc42d527b29447094913b (patch)
treedd7d4ed795acbfc46fcae0642c06df6d6459f57c /python/phply/phply.SlackBuild
parent62e62a903653430853d933e89295a5aca02a3003 (diff)
downloadslackbuilds-514e76fd62ec642188bbc42d527b29447094913b.tar.gz
slackbuilds-514e76fd62ec642188bbc42d527b29447094913b.tar.xz
python/phply: Fix collision, script update.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/phply/phply.SlackBuild')
-rw-r--r--python/phply/phply.SlackBuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/python/phply/phply.SlackBuild b/python/phply/phply.SlackBuild
index f18e87bb57..d708a7c5ec 100644
--- a/python/phply/phply.SlackBuild
+++ b/python/phply/phply.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=phply
VERSION=${VERSION:-1.2.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,16 +69,24 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py test
python setup.py install --root=$PKG
+# Find python version
+py2=$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
+# Clean up to avoid collisions with other packages
+rm -r $PKG/usr/lib${LIBDIRSUFFIX}/python$py2/site-packages/tests
+
# Python 3 support.
# Be aware that the python3 tests downloads a
# newer version of nose in /tmp to succeed.
# This newer version of nose does not get installed on your system.
if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py test
python3 setup.py install --root=$PKG
+
+ # Find python3 version
+ py3=$(python3 -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
+ # Clean up to avoid collisions with other packages
+ rm -r $PKG/usr/lib${LIBDIRSUFFIX}/python$py3/site-packages/tests
fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \