summaryrefslogtreecommitdiffstats
path: root/python/planes
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-15 16:28:44 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-19 18:40:18 +0700
commitfd537802caa44fc37039e76aa832907e5f862af9 (patch)
tree6401636534835239d186ef4a8a11ead3e5560ad8 /python/planes
parent8aa06c029fd6ca90da43b0550e37fc16f2d2f9ad (diff)
downloadslackbuilds-fd537802caa44fc37039e76aa832907e5f862af9.tar.gz
slackbuilds-fd537802caa44fc37039e76aa832907e5f862af9.tar.xz
python/planes: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/planes')
-rw-r--r--python/planes/planes.SlackBuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/python/planes/planes.SlackBuild b/python/planes/planes.SlackBuild
index a296bd7d99..27293a8bbc 100644
--- a/python/planes/planes.SlackBuild
+++ b/python/planes/planes.SlackBuild
@@ -55,7 +55,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true