summaryrefslogtreecommitdiffstats
path: root/python/py
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-21 21:32:18 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-06-02 01:02:26 +0700
commitca5332e18d9fc01656159ec4042460fa54e9154d (patch)
treee1a8de55bf01f67ef94c91b0376bad6c1e999aaa /python/py
parent3b2c9f927538fa8c0656c5a5ed202c01da6da020 (diff)
downloadslackbuilds-ca5332e18d9fc01656159ec4042460fa54e9154d.tar.gz
slackbuilds-ca5332e18d9fc01656159ec4042460fa54e9154d.tar.xz
python/py: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/py')
-rw-r--r--python/py/README7
-rw-r--r--python/py/py.SlackBuild8
2 files changed, 6 insertions, 9 deletions
diff --git a/python/py/README b/python/py/README
index 1667c95551..0a1986eacb 100644
--- a/python/py/README
+++ b/python/py/README
@@ -1,7 +1,8 @@
-The py lib is a Python development support library featuring the following tools and
-modules:
+The py lib is a Python development support library featuring the
+following tools and modules:
py.path: uniform local and svn path objects
py.apipkg: explicit API control and lazy-importing
py.iniconfig: easy parsing of .ini files
-py.code: dynamic code generation and introspection (deprecated, moved to pytest).
+py.code: dynamic code generation and introspection (deprecated, moved to
+pytest).
diff --git a/python/py/py.SlackBuild b/python/py/py.SlackBuild
index 38cd006126..f00d31ff41 100644
--- a/python/py/py.SlackBuild
+++ b/python/py/py.SlackBuild
@@ -69,12 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true