summaryrefslogtreecommitdiffstats
path: root/python/pydblite
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2013-11-11 09:13:05 -0600
committer Robby Workman <rworkman@slackbuilds.org>2013-11-11 10:53:36 -0600
commit8a720b7565ebb622a1c75889a9266eb31f3f1305 (patch)
treedee479bddefca7ee732eac31503e5e512e5d34a5 /python/pydblite
parent192892025092432f653c2c3c8f8ccbadc381d7ee (diff)
downloadslackbuilds-8a720b7565ebb622a1c75889a9266eb31f3f1305.tar.gz
slackbuilds-8a720b7565ebb622a1c75889a9266eb31f3f1305.tar.xz
various: fixes for new templates (find/fixperms)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/pydblite')
-rw-r--r--python/pydblite/pydblite.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/pydblite/pydblite.SlackBuild b/python/pydblite/pydblite.SlackBuild
index ea657bb32c..7686037e45 100644
--- a/python/pydblite/pydblite.SlackBuild
+++ b/python/pydblite/pydblite.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=pydblite
VERSION=${VERSION:-2.7}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -54,11 +54,11 @@ rm -rf $SRCNAM-$VERSION
unzip $CWD/$SRCNAM-$VERSION.zip
cd $SRCNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py build install --root=$PKG