summaryrefslogtreecommitdiffstats
path: root/python/pydot/pydot.SlackBuild
diff options
context:
space:
mode:
author Daniil Bratashov <dn2010@gmail.com>2016-09-27 23:08:16 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-01 07:17:04 +0700
commitc1cdc9fd417212dafa9cefa895713fa2ab6b4a49 (patch)
tree18c96d26ffa7171331e738b527c497bca97fa6cf /python/pydot/pydot.SlackBuild
parentc94e1fb56f4b394c8c7cce12e9a6e8a3f51732d3 (diff)
downloadslackbuilds-c1cdc9fd417212dafa9cefa895713fa2ab6b4a49.tar.gz
slackbuilds-c1cdc9fd417212dafa9cefa895713fa2ab6b4a49.tar.xz
python/pydot: Update DOWNLOAD url + switch to i586.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pydot/pydot.SlackBuild')
-rw-r--r--python/pydot/pydot.SlackBuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/python/pydot/pydot.SlackBuild b/python/pydot/pydot.SlackBuild
index f5311ad7b5..2fe9033d72 100644
--- a/python/pydot/pydot.SlackBuild
+++ b/python/pydot/pydot.SlackBuild
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pydot
-VERSION=1.0.28
+VERSION=${VERSION:-1.0.28}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -50,22 +50,21 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
# remove wrongly installed docs
rm -f $PKG/usr/{LICENSE,README}
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install