summaryrefslogtreecommitdiffstats
path: root/python/pyicu
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2022-01-23 11:22:09 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-01-25 14:44:38 +0700
commit49a04b746c10a20e2b45d6ed763bb53af5f5f6de (patch)
tree368c216c1e11afe2ae92cb5d67e49d347f211754 /python/pyicu
parenta706820fa0860bb7e46f2dc1f33d666f214d8d39 (diff)
downloadslackbuilds-49a04b746c10a20e2b45d6ed763bb53af5f5f6de.tar.gz
slackbuilds-49a04b746c10a20e2b45d6ed763bb53af5f5f6de.tar.xz
python/python2-pyicu: Renamed from pyicu and updated for version 2.8
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pyicu')
-rw-r--r--python/pyicu/README2
-rw-r--r--python/pyicu/pyicu.SlackBuild85
-rw-r--r--python/pyicu/pyicu.info10
-rw-r--r--python/pyicu/slack-desc19
4 files changed, 0 insertions, 116 deletions
diff --git a/python/pyicu/README b/python/pyicu/README
deleted file mode 100644
index 86100eea25..0000000000
--- a/python/pyicu/README
+++ /dev/null
@@ -1,2 +0,0 @@
-PyICU is a Python extension wrapping IBM's International
-Components for Unicode C++ library (ICU).
diff --git a/python/pyicu/pyicu.SlackBuild b/python/pyicu/pyicu.SlackBuild
deleted file mode 100644
index 031157948d..0000000000
--- a/python/pyicu/pyicu.SlackBuild
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for pyicu
-
-# Copyright 2009-2021 Heinz Wiesinger, Amsterdam, The Netherlands
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pyicu
-VERSION=${VERSION:-2.7.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-SRCNAM=PyICU
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES PKG-INFO README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/pyicu/pyicu.info b/python/pyicu/pyicu.info
deleted file mode 100644
index 312b86848d..0000000000
--- a/python/pyicu/pyicu.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyicu"
-VERSION="2.7.4"
-HOMEPAGE="https://github.com/ovalhub/pyicu"
-DOWNLOAD="https://files.pythonhosted.org/packages/6b/ef/d495df371dcbfc36dc68b029495bbc386f59e3c4c6c5f327fc8b9c52c8b1/PyICU-2.7.4.tar.gz"
-MD5SUM="9911386516c555d21792843259d84f32"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Heinz Wiesinger"
-EMAIL="pprkut@slackbuilds.org"
diff --git a/python/pyicu/slack-desc b/python/pyicu/slack-desc
deleted file mode 100644
index 781b011ac9..0000000000
--- a/python/pyicu/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pyicu: pyicu (python wrapper for icu4c)
-pyicu:
-pyicu: PyICU is a Python extension wrapping IBM's International
-pyicu: Components for Unicode C++ library (ICU).
-pyicu:
-pyicu: Homepage: https://github.com/ovalhub/pyicu
-pyicu:
-pyicu:
-pyicu:
-pyicu:
-pyicu: