summaryrefslogtreecommitdiffstats
path: root/python/pyicu
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2017-04-04 21:50:57 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-08 06:57:46 +0700
commit7bfe32588c6222336c71256da8d050e44cbde035 (patch)
tree00e1a211967223635ffd6efb547eb9c7deeb65be /python/pyicu
parent76e16b5e5e44c84f14a8d403318424dc9d7835f2 (diff)
downloadslackbuilds-7bfe32588c6222336c71256da8d050e44cbde035.tar.gz
slackbuilds-7bfe32588c6222336c71256da8d050e44cbde035.tar.xz
python/pyicu: Add python3 support.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/pyicu')
-rw-r--r--python/pyicu/README5
-rw-r--r--python/pyicu/pyicu.SlackBuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/python/pyicu/README b/python/pyicu/README
index 86100eea25..7473d2b4a8 100644
--- a/python/pyicu/README
+++ b/python/pyicu/README
@@ -1,2 +1,7 @@
PyICU is a Python extension wrapping IBM's International
Components for Unicode C++ library (ICU).
+
+python3 is an optional dependency. You need to set PYTHON3=yes,
+for example:
+
+ PYTHON3=yes ./pyicu.SlackBuild
diff --git a/python/pyicu/pyicu.SlackBuild b/python/pyicu/pyicu.SlackBuild
index f55f1c17dd..d9f91aeb08 100644
--- a/python/pyicu/pyicu.SlackBuild
+++ b/python/pyicu/pyicu.SlackBuild
@@ -59,6 +59,11 @@ find -L . \
python setup.py install --root=$PKG
+if [ "${PYTHON3:-no}" = "yes" ]; then
+ rm -rf build
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true