summaryrefslogtreecommitdiffstats
path: root/python/python-joblib
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-11-20 08:55:24 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-11-20 08:55:24 +0700
commit69b32d97cef5c870fb1a81874d187aa72820cb1a (patch)
tree07ccba2d31752e73c7c9a224fa9e74e513d41b98 /python/python-joblib
parentbfc172aaa7400ceb45a8436154a973126bfaf130 (diff)
downloadslackbuilds-69b32d97cef5c870fb1a81874d187aa72820cb1a.tar.gz
slackbuilds-69b32d97cef5c870fb1a81874d187aa72820cb1a.tar.xz
python/python-joblib: Removed (use python3-joblib).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-joblib')
-rw-r--r--python/python-joblib/README3
-rw-r--r--python/python-joblib/python-joblib.SlackBuild100
-rw-r--r--python/python-joblib/python-joblib.info10
-rw-r--r--python/python-joblib/slack-desc19
4 files changed, 0 insertions, 132 deletions
diff --git a/python/python-joblib/README b/python/python-joblib/README
deleted file mode 100644
index cbaef36c15..0000000000
--- a/python/python-joblib/README
+++ /dev/null
@@ -1,3 +0,0 @@
-Joblib is a set of tools to provide lightweight pipelining in
-Python. Joblib is optimized to be fast and robust on large data in
-particular and has specific optimizations for numpy arrays.
diff --git a/python/python-joblib/python-joblib.SlackBuild b/python/python-joblib/python-joblib.SlackBuild
deleted file mode 100644
index 41a66e42d5..0000000000
--- a/python/python-joblib/python-joblib.SlackBuild
+++ /dev/null
@@ -1,100 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python-joblib
-
-# Copyright 2019-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python-joblib
-VERSION=${VERSION:-1.2.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-SRCNAM=joblib
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- LICENSE.txt README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-joblib/python-joblib.info b/python/python-joblib/python-joblib.info
deleted file mode 100644
index d1d7432dce..0000000000
--- a/python/python-joblib/python-joblib.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-joblib"
-VERSION="1.2.0"
-HOMEPAGE="https://joblib.readthedocs.io/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/j/joblib/joblib-1.2.0.tar.gz"
-MD5SUM="928a19e66a10f6cda32fb004440c70fb"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/python-joblib/slack-desc b/python/python-joblib/slack-desc
deleted file mode 100644
index a0f856dad9..0000000000
--- a/python/python-joblib/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-joblib: python-joblib (lightweight pipelining in Python)
-python-joblib:
-python-joblib: Joblib is a set of tools to provide lightweight pipelining in Python.
-python-joblib: Joblib is optimized to be fast and robust on large data in particular
-python-joblib: and has specific optimizations for numpy arrays.
-python-joblib:
-python-joblib:
-python-joblib:
-python-joblib:
-python-joblib:
-python-joblib: