summaryrefslogtreecommitdiffstats
path: root/python/python-poppler-qt4/python-poppler-qt4.SlackBuild
diff options
context:
space:
mode:
author Michales Michaloudes <korgie@gmail.com>2017-02-08 22:54:39 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-02-11 07:24:30 +0700
commit77a9ada29bde691b252c87e47de47f92e4a1a64e (patch)
tree056371e5960c96091d8ea708534273b87396c461 /python/python-poppler-qt4/python-poppler-qt4.SlackBuild
parentf70efdce75daaba20277cdb57c868c6060dc8458 (diff)
downloadslackbuilds-77a9ada29bde691b252c87e47de47f92e4a1a64e.tar.gz
slackbuilds-77a9ada29bde691b252c87e47de47f92e4a1a64e.tar.xz
python/python-poppler-qt4: Updated for version 0.24.0.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/python-poppler-qt4/python-poppler-qt4.SlackBuild')
-rw-r--r--python/python-poppler-qt4/python-poppler-qt4.SlackBuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/python/python-poppler-qt4/python-poppler-qt4.SlackBuild b/python/python-poppler-qt4/python-poppler-qt4.SlackBuild
index a22298763f..f278e9eee8 100644
--- a/python/python-poppler-qt4/python-poppler-qt4.SlackBuild
+++ b/python/python-poppler-qt4/python-poppler-qt4.SlackBuild
@@ -4,13 +4,13 @@
# Michales - clavisound - Michaloudes korgie@gmail.com <2012>
PRGNAM=python-poppler-qt4
-VERSION=${VERSION:-0.16.2}
+VERSION=${VERSION:-0.24.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -21,8 +21,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -43,22 +43,22 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
-cat $CWD/*.patch | patch -p 1
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --prefix $PKG/usr
+python setup.py build
+python setup.py install --root $PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- ChangeLog README TODO INSTALL LICENSE \
+ ChangeLog README.rst TODO INSTALL LICENSE \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild