summaryrefslogtreecommitdiffstats
path: root/python/python-vatnumber/python-vatnumber.SlackBuild
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-07-26 20:49:22 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-07-26 20:49:22 +0700
commit6af04110360b1af17aa7fafed64d5193f73588fc (patch)
treeb3f7c2664260fcdbd70be49539d4c6f8ec7c8ceb /python/python-vatnumber/python-vatnumber.SlackBuild
parent26b0053fe9a51bdbb544d9f626e12d7f2fb8a1a3 (diff)
downloadslackbuilds-6af04110360b1af17aa7fafed64d5193f73588fc.tar.gz
slackbuilds-6af04110360b1af17aa7fafed64d5193f73588fc.tar.xz
python/python-vatnumber: Updated for version 1.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-vatnumber/python-vatnumber.SlackBuild')
-rw-r--r--python/python-vatnumber/python-vatnumber.SlackBuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/python/python-vatnumber/python-vatnumber.SlackBuild b/python/python-vatnumber/python-vatnumber.SlackBuild
index ba754c81fd..fd93e5bd30 100644
--- a/python/python-vatnumber/python-vatnumber.SlackBuild
+++ b/python/python-vatnumber/python-vatnumber.SlackBuild
@@ -24,13 +24,13 @@
PRGNAM=python-vatnumber
SRCNAM=vatnumber
-VERSION=${VERSION:-1.1}
+VERSION=${VERSION:-1.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -43,8 +43,8 @@ OUTPUT=${OUTPUT:-/tmp}
DOCS="LICENSE README"
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -57,6 +57,8 @@ else
LIBDIRSUFFIX=""
fi
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
@@ -68,13 +70,13 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py build || exit 1
+python setup.py build
-python setup.py install --root $PKG || exit 1
+python setup.py install --root $PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION