summaryrefslogtreecommitdiffstats
path: root/python/python2-cheetah
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-06 17:11:13 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:47 +0700
commit2736c86213709c55205311ac6b56905d1315b6db (patch)
treea0650dbe3663e9292b1678ed370aca559fdc55a2 /python/python2-cheetah
parentfd743313af52c72de96b367b50e3d2ec9808cfd1 (diff)
downloadslackbuilds-2736c86213709c55205311ac6b56905d1315b6db.tar.gz
slackbuilds-2736c86213709c55205311ac6b56905d1315b6db.tar.xz
python/python-cheetah: Renamed python2-cheetah.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-cheetah')
-rw-r--r--python/python2-cheetah/README5
-rw-r--r--python/python2-cheetah/python2-cheetah.SlackBuild73
-rw-r--r--python/python2-cheetah/python2-cheetah.info10
-rw-r--r--python/python2-cheetah/slack-desc19
4 files changed, 107 insertions, 0 deletions
diff --git a/python/python2-cheetah/README b/python/python2-cheetah/README
new file mode 100644
index 0000000000..f2276cedb2
--- /dev/null
+++ b/python/python2-cheetah/README
@@ -0,0 +1,5 @@
+Cheetah is an open source template engine and code generation tool,
+written in Python. It can be used standalone or combined with other
+tools and frameworks. Web development is its principle use, but Cheetah
+is very flexible and is also being used to generate C++ game code, Java,
+sql, form emails and even Python code.
diff --git a/python/python2-cheetah/python2-cheetah.SlackBuild b/python/python2-cheetah/python2-cheetah.SlackBuild
new file mode 100644
index 0000000000..1b2a97474c
--- /dev/null
+++ b/python/python2-cheetah/python2-cheetah.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for python-cheetah
+
+# Written by Nikos Skalkotos (skalkoto@gmail.com)
+
+PRGNAM=python2-cheetah
+VERSION=${VERSION:-2.4.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=Cheetah
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar -xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES LICENSE TODO PKG-INFO README.markdown\
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+
diff --git a/python/python2-cheetah/python2-cheetah.info b/python/python2-cheetah/python2-cheetah.info
new file mode 100644
index 0000000000..a8ce182b24
--- /dev/null
+++ b/python/python2-cheetah/python2-cheetah.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-cheetah"
+VERSION="2.4.4"
+HOMEPAGE="http://www.cheetahtemplate.org/"
+DOWNLOAD="https://pypi.python.org/packages/source/C/Cheetah/Cheetah-2.4.4.tar.gz"
+MD5SUM="853917116e731afbc8c8a43c37e6ddba"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Nikos Skalkotos"
+EMAIL="skalkoto@gmail.com"
diff --git a/python/python2-cheetah/slack-desc b/python/python2-cheetah/slack-desc
new file mode 100644
index 0000000000..a58251deb5
--- /dev/null
+++ b/python/python2-cheetah/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-cheetah: python2-cheetah (Python-Powered Template Engine)
+python2-cheetah:
+python2-cheetah: Cheetah is an open source template engine and code generation tool,
+python2-cheetah: written in Python. It can be used standalone or combined with other
+python2-cheetah: tools and frameworks. Web development is its principle use, but
+python2-cheetah: Cheetah is very flexible and is also being used to generate C++ game
+python2-cheetah: code, Java, sql, form emails and even Python code.
+python2-cheetah:
+python2-cheetah: Homepage: http://www.cheetahtemplate.org/
+python2-cheetah:
+python2-cheetah: