summaryrefslogtreecommitdiffstats
path: root/python/python2-django-tagging
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-14 21:34:36 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-19 18:39:59 +0700
commitd8fb155c35bce39f90136fb22486f6d98be6b5ec (patch)
treeddfe82bbe077e4f4063bb9a671be795e57141a3e /python/python2-django-tagging
parent44190459819d2ab2adacb7be38eca4fe6d15a333 (diff)
downloadslackbuilds-d8fb155c35bce39f90136fb22486f6d98be6b5ec.tar.gz
slackbuilds-d8fb155c35bce39f90136fb22486f6d98be6b5ec.tar.xz
python/python-django-tagging: Renamed python2-django-tagging.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-django-tagging')
-rw-r--r--python/python2-django-tagging/README5
-rw-r--r--python/python2-django-tagging/python2-django-tagging.SlackBuild84
-rw-r--r--python/python2-django-tagging/python2-django-tagging.info10
-rw-r--r--python/python2-django-tagging/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/python/python2-django-tagging/README b/python/python2-django-tagging/README
new file mode 100644
index 0000000000..c1373ede9a
--- /dev/null
+++ b/python/python2-django-tagging/README
@@ -0,0 +1,5 @@
+python-django-tagging (Generic tagging application for Django)
+
+This is a generic tagging application for Django projects, which allows
+association of a number of tags with any Model instance and makes
+retrieval of tags simple.
diff --git a/python/python2-django-tagging/python2-django-tagging.SlackBuild b/python/python2-django-tagging/python2-django-tagging.SlackBuild
new file mode 100644
index 0000000000..bcef413711
--- /dev/null
+++ b/python/python2-django-tagging/python2-django-tagging.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for python-django-tagging
+
+# Copyright 2015, 2016 Mario Preksavec, Zagreb, Croatia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python2-django-tagging
+SRCNAM=django-tagging
+VERSION=${VERSION:-0.4.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.txt LICENSE.txt README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python2-django-tagging/python2-django-tagging.info b/python/python2-django-tagging/python2-django-tagging.info
new file mode 100644
index 0000000000..badb7583d7
--- /dev/null
+++ b/python/python2-django-tagging/python2-django-tagging.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-django-tagging"
+VERSION="0.4.3"
+HOMEPAGE="https://pypi.python.org/pypi/django-tagging"
+DOWNLOAD="https://pypi.debian.net/django-tagging/django-tagging-0.4.3.tar.gz"
+MD5SUM="0da5b6090a4352a8edcaff0f51c37adb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python2-django"
+MAINTAINER="Mario Preksavec"
+EMAIL="mario at slackware dot hr"
diff --git a/python/python2-django-tagging/slack-desc b/python/python2-django-tagging/slack-desc
new file mode 100644
index 0000000000..46d7a91307
--- /dev/null
+++ b/python/python2-django-tagging/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-django-tagging: python2-django-tagging (Generic tagging application for Django)
+python2-django-tagging:
+python2-django-tagging: This is a generic tagging application for Django projects, which
+python2-django-tagging: allows association of a number of tags with any Model instance and
+python2-django-tagging: makes retrieval of tags simple.
+python2-django-tagging:
+python2-django-tagging: Homepage: https://pypi.python.org/pypi/django-tagging/
+python2-django-tagging:
+python2-django-tagging:
+python2-django-tagging:
+python2-django-tagging: