summaryrefslogtreecommitdiffstats
path: root/python/python2-pyhamcrest
diff options
context:
space:
mode:
author Arn0 <yth@ythogtha.org>2023-07-04 14:18:18 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-06 11:23:34 +0700
commit19ee9a4e5d1baa674f015dcd73504cad853f6ca0 (patch)
tree505c21aee53c89dc1976806f9c7afa0a3183dc05 /python/python2-pyhamcrest
parent13b9c273f6e63168a241ff970aa125fca4515976 (diff)
downloadslackbuilds-19ee9a4e5d1baa674f015dcd73504cad853f6ca0.tar.gz
slackbuilds-19ee9a4e5d1baa674f015dcd73504cad853f6ca0.tar.xz
python/python2-pyhamcrest: Removed: obsolete, outdated, unmaintained, not working, or not needed anymore.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-pyhamcrest')
-rw-r--r--python/python2-pyhamcrest/README6
-rw-r--r--python/python2-pyhamcrest/python2-pyhamcrest.SlackBuild98
-rw-r--r--python/python2-pyhamcrest/python2-pyhamcrest.info10
-rw-r--r--python/python2-pyhamcrest/slack-desc19
4 files changed, 0 insertions, 133 deletions
diff --git a/python/python2-pyhamcrest/README b/python/python2-pyhamcrest/README
deleted file mode 100644
index 4adff124b9..0000000000
--- a/python/python2-pyhamcrest/README
+++ /dev/null
@@ -1,6 +0,0 @@
-PyHamcrest is a framework for writing matcher objects,
-allowing you to declaratively define “match” rules.
-There are a number of situations where matchers are
-invaluable, such as UI validation, or data filtering,
-but it is in the area of writing flexible tests that
-matchers are most commonly used.
diff --git a/python/python2-pyhamcrest/python2-pyhamcrest.SlackBuild b/python/python2-pyhamcrest/python2-pyhamcrest.SlackBuild
deleted file mode 100644
index 81f97bce35..0000000000
--- a/python/python2-pyhamcrest/python2-pyhamcrest.SlackBuild
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python2-pyhamcrest
-
-# Yth | Pont-en-Royans, France | yth@ythogtha.org
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python2-pyhamcrest
-SRCNAM=PyHamcrest
-VERSION=${VERSION:-1.10.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- LICENSE* README* CHANGES* \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-pyhamcrest/python2-pyhamcrest.info b/python/python2-pyhamcrest/python2-pyhamcrest.info
deleted file mode 100644
index a5048baa32..0000000000
--- a/python/python2-pyhamcrest/python2-pyhamcrest.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python2-pyhamcrest"
-VERSION="1.10.1"
-HOMEPAGE="https://github.com/hamcrest/PyHamcrest"
-DOWNLOAD="https://pypi.python.org/packages/source/P/PyHamcrest/PyHamcrest-1.10.1.tar.gz"
-MD5SUM="6be265e4704aacd20cf8e4dd4eeb7dd3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Yth - Arnaud"
-EMAIL="yth@ythogtha.org"
diff --git a/python/python2-pyhamcrest/slack-desc b/python/python2-pyhamcrest/slack-desc
deleted file mode 100644
index 9ece5d7529..0000000000
--- a/python/python2-pyhamcrest/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python2-pyhamcrest: python2-pyhamcrest (Hamcrest framework for matcher objects)
-python2-pyhamcrest:
-python2-pyhamcrest: PyHamcrest is a framework for writing matcher objects, allowing you
-python2-pyhamcrest: to declaratively define "match" rules.
-python2-pyhamcrest:
-python2-pyhamcrest: There are a number of situations where matchers are invaluable,
-python2-pyhamcrest: such as UI validation, or data filtering.
-python2-pyhamcrest: But it is in the area of writing flexible tests that matchers are
-python2-pyhamcrest: most commonly used.
-python2-pyhamcrest:
-python2-pyhamcrest: https://github.com/hamcrest/PyHamcrest