summaryrefslogtreecommitdiffstats
path: root/python/python3-babel
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2020-10-28 14:56:34 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-10-31 11:15:14 +0700
commitf6fc38c9693f99db724922f99fde7d619853ebbf (patch)
tree78ea11fea9737c25c5dbcbc5db586459d49679fc /python/python3-babel
parentd88e47c2193bfd63badcaeb7738653afb8c127bb (diff)
downloadslackbuilds-f6fc38c9693f99db724922f99fde7d619853ebbf.tar.gz
slackbuilds-f6fc38c9693f99db724922f99fde7d619853ebbf.tar.xz
python/python3-babel: Support Python 3.9.
Signed-off-by: Benjamin Trigona-Harany <slackbuilds@jaxartes.net> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-babel')
-rw-r--r--python/python3-babel/python3-babel.SlackBuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/python/python3-babel/python3-babel.SlackBuild b/python/python3-babel/python3-babel.SlackBuild
index 9d7fe28dda..6d8fa8e156 100644
--- a/python/python3-babel/python3-babel.SlackBuild
+++ b/python/python3-babel/python3-babel.SlackBuild
@@ -73,6 +73,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i "s/getiterator/iter/" scripts/import_cldr.py # support Python 3.9
+sed -i "s/elem.getchildren()/list(elem)/" scripts/import_cldr.py # support Python 3.9
ln -s $CWD/core.zip cldr/cldr-core-$CLDRVER.zip
python3 setup.py import_cldr
python3 setup.py install --root=$PKG