summaryrefslogtreecommitdiffstats
path: root/python/python3-simplegeneric
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2017-04-16 18:24:01 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-16 18:24:01 +0700
commitc1728e70225fd919093a8408c45825d76171c55f (patch)
tree8c537abeeb9843b670f0ed25767071464acadad3 /python/python3-simplegeneric
parentb46d9037b36ef37082aca937cf21912a54f53636 (diff)
downloadslackbuilds-c1728e70225fd919093a8408c45825d76171c55f.tar.gz
slackbuilds-c1728e70225fd919093a8408c45825d76171c55f.tar.xz
python/python3-simplegeneric: Added (Generic functions for Python3).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-simplegeneric')
-rw-r--r--python/python3-simplegeneric/README3
-rw-r--r--python/python3-simplegeneric/python3-simplegeneric.SlackBuild70
-rw-r--r--python/python3-simplegeneric/python3-simplegeneric.info10
-rw-r--r--python/python3-simplegeneric/slack-desc19
4 files changed, 102 insertions, 0 deletions
diff --git a/python/python3-simplegeneric/README b/python/python3-simplegeneric/README
new file mode 100644
index 0000000000..390479b2e8
--- /dev/null
+++ b/python/python3-simplegeneric/README
@@ -0,0 +1,3 @@
+The simplegeneric module lets you define simple single-dispatch
+generic functions, akin to Python's built-in generic functions like
+len(), iter() and so on.
diff --git a/python/python3-simplegeneric/python3-simplegeneric.SlackBuild b/python/python3-simplegeneric/python3-simplegeneric.SlackBuild
new file mode 100644
index 0000000000..188c796a8c
--- /dev/null
+++ b/python/python3-simplegeneric/python3-simplegeneric.SlackBuild
@@ -0,0 +1,70 @@
+#!/bin/sh
+
+# Slackware build script for python3-simplegeneric
+
+# Copyright 2012 Mikko Värri, Finland
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=simplegeneric
+PRGNAM=python3-$SRCNAM
+VERSION=${VERSION:-0.8.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+unzip $CWD/$SRCNAM-$VERSION.zip
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-simplegeneric/python3-simplegeneric.info b/python/python3-simplegeneric/python3-simplegeneric.info
new file mode 100644
index 0000000000..3b85350a52
--- /dev/null
+++ b/python/python3-simplegeneric/python3-simplegeneric.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-simplegeneric"
+VERSION="0.8.1"
+HOMEPAGE="http://pypi.python.org/pypi/simplegeneric"
+DOWNLOAD="http://pypi.python.org/packages/source/s/simplegeneric/simplegeneric-0.8.1.zip"
+MD5SUM="f9c1fab00fd981be588fc32759f474e3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-simplegeneric/slack-desc b/python/python3-simplegeneric/slack-desc
new file mode 100644
index 0000000000..b3154bd9b2
--- /dev/null
+++ b/python/python3-simplegeneric/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-simplegeneric: python3-simplegeneric (Simple generic functions for Python 3)
+python3-simplegeneric:
+python3-simplegeneric: The simplegeneric module lets you define simple single-dispatch
+python3-simplegeneric: generic functions, akin to Python's built-in generic functions like
+python3-simplegeneric: len(), iter() and so on.
+python3-simplegeneric:
+python3-simplegeneric:
+python3-simplegeneric:
+python3-simplegeneric:
+python3-simplegeneric:
+python3-simplegeneric: