summaryrefslogtreecommitdiffstats
path: root/python/python3-six
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2017-04-16 18:07:37 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-16 18:07:37 +0700
commit44cc81242b1cf0eed44158ca9e1403b39f8aebad (patch)
tree8784c6af26510f7b808584597c43b40624677e92 /python/python3-six
parenta94c3e07d85191b4e46f9b9533a7e791f64053ea (diff)
downloadslackbuilds-44cc81242b1cf0eed44158ca9e1403b39f8aebad.tar.gz
slackbuilds-44cc81242b1cf0eed44158ca9e1403b39f8aebad.tar.xz
python/python3-six: Added (Python 2 and 3 compatibility utilities).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-six')
-rw-r--r--python/python3-six/README4
-rw-r--r--python/python3-six/python3-six.SlackBuild73
-rw-r--r--python/python3-six/python3-six.info10
-rw-r--r--python/python3-six/slack-desc19
4 files changed, 106 insertions, 0 deletions
diff --git a/python/python3-six/README b/python/python3-six/README
new file mode 100644
index 0000000000..ee25e72d18
--- /dev/null
+++ b/python/python3-six/README
@@ -0,0 +1,4 @@
+Six is a Python 2 and 3 compatibility library. It provides utility functions for
+smoothing over the differences between the Python versions with the goal of
+writing Python code that is compatible on both Python versions. See the
+documentation for more information on what is provided.
diff --git a/python/python3-six/python3-six.SlackBuild b/python/python3-six/python3-six.SlackBuild
new file mode 100644
index 0000000000..5916a16ad9
--- /dev/null
+++ b/python/python3-six/python3-six.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for python3-six
+
+# Copyright 2012-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=six
+PRGNAM=python3-$SRCNAM
+VERSION=${VERSION:-1.10.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-six/python3-six.info b/python/python3-six/python3-six.info
new file mode 100644
index 0000000000..71b4b9ab7e
--- /dev/null
+++ b/python/python3-six/python3-six.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-six"
+VERSION="1.10.0"
+HOMEPAGE="http://pypi.python.org/pypi/six/"
+DOWNLOAD="http://pypi.python.org/packages/source/s/six/six-1.10.0.tar.gz"
+MD5SUM="34eed507548117b2ab523ab14b2f8b55"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-six/slack-desc b/python/python3-six/slack-desc
new file mode 100644
index 0000000000..0694e82700
--- /dev/null
+++ b/python/python3-six/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-six: python3-six (Python 2 and 3 compatibility utilities)
+python3-six:
+python3-six: Six is a Python 2 and 3 compatibility library. It provides utility
+python3-six: functions for smoothing over the differences between the Python
+python3-six: versions with the goal of writing Python code that is compatible on
+python3-six: both Python versions. See the documentation for more information on
+python3-six: what is provided.
+python3-six:
+python3-six:
+python3-six:
+python3-six: