summaryrefslogtreecommitdiffstats
path: root/python/tzdata
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2022-06-04 02:56:17 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-06-04 10:37:13 +0700
commit48c0b15ccabfc82ce53a6c8b6e5fc0182d58de08 (patch)
tree70d93671656dc2b7030a9326524d0bcd39c11ad9 /python/tzdata
parentc6d8900231de08c2ccd9890e9b66956b91990254 (diff)
downloadslackbuilds-48c0b15ccabfc82ce53a6c8b6e5fc0182d58de08.tar.gz
slackbuilds-48c0b15ccabfc82ce53a6c8b6e5fc0182d58de08.tar.xz
python/tzdata: Added (Python package providing IANA time zone data)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/tzdata')
-rw-r--r--python/tzdata/README6
-rw-r--r--python/tzdata/slack-desc19
-rw-r--r--python/tzdata/tzdata.SlackBuild104
-rw-r--r--python/tzdata/tzdata.info10
4 files changed, 139 insertions, 0 deletions
diff --git a/python/tzdata/README b/python/tzdata/README
new file mode 100644
index 0000000000..ea7fca6738
--- /dev/null
+++ b/python/tzdata/README
@@ -0,0 +1,6 @@
+tzdata (Python package providing IANA time zone data)
+
+This is a Python package containing zic-compiled binaries for the IANA
+time zone database. It is intended to be a fallback for systems that
+do not have system time zone data installed (or don't have it
+installed in a standard location), as a part of PEP 615
diff --git a/python/tzdata/slack-desc b/python/tzdata/slack-desc
new file mode 100644
index 0000000000..c6e510664b
--- /dev/null
+++ b/python/tzdata/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+tzdata: tzdata (Python package providing IANA time zone data)
+tzdata:
+tzdata: This is a Python package containing zic-compiled binaries for the IANA
+tzdata: time zone database. It is intended to be a fallback for systems that
+tzdata: do not have system time zone data installed (or don't have it
+tzdata: installed in a standard location), as a part of PEP 615
+tzdata:
+tzdata: Homepage: https://github.com/python/tzdata
+tzdata:
+tzdata:
+tzdata:
diff --git a/python/tzdata/tzdata.SlackBuild b/python/tzdata/tzdata.SlackBuild
new file mode 100644
index 0000000000..74f694cb80
--- /dev/null
+++ b/python/tzdata/tzdata.SlackBuild
@@ -0,0 +1,104 @@
+#!/bin/bash
+
+# Slackware build script for tzdata
+
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=tzdata
+SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
+VERSION=${VERSION:-2022.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+#add basic setup.py
+cat << EOF > setup.py
+from setuptools import setup
+
+if __name__ == '__main__':
+ setup()
+EOF
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/tzdata/tzdata.info b/python/tzdata/tzdata.info
new file mode 100644
index 0000000000..459c436361
--- /dev/null
+++ b/python/tzdata/tzdata.info
@@ -0,0 +1,10 @@
+PRGNAM="tzdata"
+VERSION="2022.1"
+HOMEPAGE="https://github.com/python/tzdata"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/t/tzdata/tzdata-2022.1.tar.gz"
+MD5SUM="b458f1ceb9371d9d3051de2fd2c45bb8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"