summaryrefslogtreecommitdiffstats
path: root/python/webassets
diff options
context:
space:
mode:
author Markus Reichelt <slackbuilds@mareichelt.de>2013-02-11 14:56:11 -0600
committer Erik Hanson <erik@slackbuilds.org>2013-02-14 00:26:56 -0600
commitc9812f9c85ec97d194adef048be53d51dc0df919 (patch)
tree14f1f49380da78408a61a946e94db6240db63b34 /python/webassets
parent70fb50ae446436234fc04100c65fe0ad0917b582 (diff)
downloadslackbuilds-c9812f9c85ec97d194adef048be53d51dc0df919.tar.gz
slackbuilds-c9812f9c85ec97d194adef048be53d51dc0df919.tar.xz
python/webassets: Added (Media asset management for Python)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'python/webassets')
-rw-r--r--python/webassets/README6
-rw-r--r--python/webassets/slack-desc19
-rw-r--r--python/webassets/webassets.SlackBuild86
-rw-r--r--python/webassets/webassets.info10
4 files changed, 121 insertions, 0 deletions
diff --git a/python/webassets/README b/python/webassets/README
new file mode 100644
index 0000000000..f6f2775b37
--- /dev/null
+++ b/python/webassets/README
@@ -0,0 +1,6 @@
+Media asset management for Python, with glue code for various
+web frameworks
+
+Merges, minifies and compresses Javascript and CSS files,
+supporting a variety of different filters, including YUI, jsmin,
+jspacker or CSS tidy. Also supports URL rewriting in CSS files.
diff --git a/python/webassets/slack-desc b/python/webassets/slack-desc
new file mode 100644
index 0000000000..fa706e396a
--- /dev/null
+++ b/python/webassets/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+webassets: webassets (Media asset management for Python)
+webassets:
+webassets: Merges, minifies and compresses Javascript and CSS files, supporting
+webassets: a variety of different filters, including YUI, jsmin, jspacker or
+webassets: CSS tidy. Also supports URL rewriting in CSS files.
+webassets:
+webassets: Homepage: https://pypi.python.org/pypi/webassets/
+webassets:
+webassets:
+webassets:
+webassets:
diff --git a/python/webassets/webassets.SlackBuild b/python/webassets/webassets.SlackBuild
new file mode 100644
index 0000000000..82e83eccda
--- /dev/null
+++ b/python/webassets/webassets.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for webassets
+
+# Copyright 2013 Markus Reichelt, Aachen, DE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
+
+PRGNAM=webassets
+VERSION=${VERSION:-0.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs/ examples/ PKG-INFO CHANGES README.rst AUTHORS LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/webassets/webassets.info b/python/webassets/webassets.info
new file mode 100644
index 0000000000..ce9920c04c
--- /dev/null
+++ b/python/webassets/webassets.info
@@ -0,0 +1,10 @@
+PRGNAM="webassets"
+VERSION="0.8"
+HOMEPAGE="http://pypi.python.org/pypi/webassets/"
+DOWNLOAD="http://pypi.python.org/packages/source/w/webassets/webassets-0.8.tar.gz"
+MD5SUM="6770429350878156e7f574ae772ebc19"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Markus Reichelt"
+EMAIL="slackbuilds@mareichelt.de"