summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2021-04-17 20:34:17 +0200
committer Robby Workman <rworkman@slackbuilds.org>2021-04-18 02:00:24 -0500
commit2de3a2a57e13175ad5a83920bea60e5de857ea85 (patch)
tree4eb17cee28f57c378a351215dd1240f35674da42 /python
parent7b9b1aebee8e91825e6d9a14824399ef76d5e18c (diff)
downloadslackbuilds-2de3a2a57e13175ad5a83920bea60e5de857ea85.tar.gz
slackbuilds-2de3a2a57e13175ad5a83920bea60e5de857ea85.tar.xz
python/python3-ipython: Removed (replaced by python/ipython).
Signed-off-by: Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
Diffstat (limited to 'python')
-rw-r--r--python/python3-ipython/README5
-rw-r--r--python/python3-ipython/python3-ipython.SlackBuild83
-rw-r--r--python/python3-ipython/python3-ipython.info10
-rw-r--r--python/python3-ipython/slack-desc19
4 files changed, 0 insertions, 117 deletions
diff --git a/python/python3-ipython/README b/python/python3-ipython/README
deleted file mode 100644
index 9ab81e2a13..0000000000
--- a/python/python3-ipython/README
+++ /dev/null
@@ -1,5 +0,0 @@
-IPython is a replacement shell for Python programming. It offers an
-enhanced Python 3 shell for the terminal.
-
-This package no longer provides IPython notebook functionality. This is
-now provided with the jupyter-notebook and python3-jupyter-ipykernel packages.
diff --git a/python/python3-ipython/python3-ipython.SlackBuild b/python/python3-ipython/python3-ipython.SlackBuild
deleted file mode 100644
index d9388b540e..0000000000
--- a/python/python3-ipython/python3-ipython.SlackBuild
+++ /dev/null
@@ -1,83 +0,0 @@
-#!/bin/sh
-
-# SlackBuild for python3-ipython
-
-# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python3-ipython
-VERSION=${VERSION:-7.22.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=ipython
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-rm $PKG/usr/bin/iptest*
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mv $PKG/usr/share/man $PKG/usr
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-# Delete now empty directory
-rm -rf $PKG/usr/share
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp \
- COPYING.rst README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-ipython/python3-ipython.info b/python/python3-ipython/python3-ipython.info
deleted file mode 100644
index b376e863b1..0000000000
--- a/python/python3-ipython/python3-ipython.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-ipython"
-VERSION="7.22.0"
-HOMEPAGE="http://ipython.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/i/ipython/ipython-7.22.0.tar.gz"
-MD5SUM="852137f493e62e5730a1245cd91e0636"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="decorator ipython_genutils python3-jedi python3-pexpect pickleshare python3-prompt_toolkit Pygments simplegeneric traitlets backcall"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-ipython/slack-desc b/python/python3-ipython/slack-desc
deleted file mode 100644
index fabef98df3..0000000000
--- a/python/python3-ipython/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-ipython: python3-ipython (an enhanced Python 3 shell)
-python3-ipython:
-python3-ipython: IPython is a multiplatform project that offers an enhanced Python 3
-python3-ipython: shell designed for efficient interactive work.
-python3-ipython:
-python3-ipython:
-python3-ipython:
-python3-ipython:
-python3-ipython:
-python3-ipython:
-python3-ipython: