summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2011-08-06 22:18:35 -0500
committer Niels Horn <niels.horn@slackbuilds.org>2011-08-11 20:28:36 -0300
commit604cf960b52ab0a27c55fc2543c0dd3ec4126ecf (patch)
tree5edac97994cc8869a3d960d7eaecc6675d0d0d79 /python
parent39fef1cc030653328d3748e6ec86f39677e212d7 (diff)
downloadslackbuilds-604cf960b52ab0a27c55fc2543c0dd3ec4126ecf.tar.gz
slackbuilds-604cf960b52ab0a27c55fc2543c0dd3ec4126ecf.tar.xz
python/virtualenv: Moved from Libraries (and bumped to 1.6.4)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/virtualenv/README3
-rw-r--r--python/virtualenv/slack-desc19
-rw-r--r--python/virtualenv/virtualenv.SlackBuild53
-rw-r--r--python/virtualenv/virtualenv.info10
4 files changed, 85 insertions, 0 deletions
diff --git a/python/virtualenv/README b/python/virtualenv/README
new file mode 100644
index 0000000000..7342676198
--- /dev/null
+++ b/python/virtualenv/README
@@ -0,0 +1,3 @@
+Virtualenv is a tool to create isolated Python environments.
+
+Virtualenv can optionally use pysetuptools during install.
diff --git a/python/virtualenv/slack-desc b/python/virtualenv/slack-desc
new file mode 100644
index 0000000000..4b8f3810df
--- /dev/null
+++ b/python/virtualenv/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+virtualenv: virtualenv
+virtualenv:
+virtualenv: virtualenv is a tool to create isolated Python environments.
+virtualenv:
+virtualenv: Homepage: http://pypi.python.org/pypi/virtualenv/
+virtualenv:
+virtualenv:
+virtualenv:
+virtualenv:
+virtualenv:
+virtualenv:
diff --git a/python/virtualenv/virtualenv.SlackBuild b/python/virtualenv/virtualenv.SlackBuild
new file mode 100644
index 0000000000..d8b1d7afc6
--- /dev/null
+++ b/python/virtualenv/virtualenv.SlackBuild
@@ -0,0 +1,53 @@
+#!/bin/sh
+
+# Slackware build script for virtualenv
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=virtualenv
+VERSION=1.6.4
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs/*.txt *.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/virtualenv/virtualenv.info b/python/virtualenv/virtualenv.info
new file mode 100644
index 0000000000..91d256cc4e
--- /dev/null
+++ b/python/virtualenv/virtualenv.info
@@ -0,0 +1,10 @@
+PRGNAM="virtualenv"
+VERSION="1.6.4"
+HOMEPAGE="http://pypi.python.org/pypi/virtualenv/"
+DOWNLOAD="http://pypi.python.org/packages/source/v/virtualenv/virtualenv-1.6.4.tar.gz"
+MD5SUM="1072b66d53c24e019a8f1304ac9d9fc5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="rworkman"