summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2022-05-20 21:14:50 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-05-21 08:25:29 +0700
commit6a04939bfa288b37d2038b8841d0f9871eca8040 (patch)
tree2dcc0a7692d23fe79847c8a2d87e59f5c7a1e2c3 /python
parent85113b0f0e88a3eb606f52c6925a67f6b7323143 (diff)
downloadslackbuilds-6a04939bfa288b37d2038b8841d0f9871eca8040.tar.gz
slackbuilds-6a04939bfa288b37d2038b8841d0f9871eca8040.tar.xz
python/Flask-Compress: Removed. Python3 script added.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/Flask-Compress/Flask-Compress.SlackBuild95
-rw-r--r--python/Flask-Compress/Flask-Compress.info10
-rw-r--r--python/Flask-Compress/README2
-rw-r--r--python/Flask-Compress/slack-desc19
4 files changed, 0 insertions, 126 deletions
diff --git a/python/Flask-Compress/Flask-Compress.SlackBuild b/python/Flask-Compress/Flask-Compress.SlackBuild
deleted file mode 100644
index 1bdffc2a55..0000000000
--- a/python/Flask-Compress/Flask-Compress.SlackBuild
+++ /dev/null
@@ -1,95 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for Flask-Compress
-
-# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=Flask-Compress
-VERSION=${VERSION:-1.3.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/Flask-Compress/Flask-Compress.info b/python/Flask-Compress/Flask-Compress.info
deleted file mode 100644
index 42e0393d2a..0000000000
--- a/python/Flask-Compress/Flask-Compress.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Flask-Compress"
-VERSION="1.3.0"
-HOMEPAGE="https://github.com/jmcarp/flask-compress"
-DOWNLOAD="https://pypi.python.org/packages/4d/ce/44564d794ff7342ba376a92c88f8bb07f604d5d30f506bcde2834311eda8/Flask-Compress-1.3.0.tar.gz"
-MD5SUM="fe3d9b75793699ceec279d37104c1a9c"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="Flask"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/Flask-Compress/README b/python/Flask-Compress/README
deleted file mode 100644
index 3c2581c753..0000000000
--- a/python/Flask-Compress/README
+++ /dev/null
@@ -1,2 +0,0 @@
-Flask-Compress allows you to easily compress your Flask application's
-responses with gzip.
diff --git a/python/Flask-Compress/slack-desc b/python/Flask-Compress/slack-desc
deleted file mode 100644
index 6bf027f6ee..0000000000
--- a/python/Flask-Compress/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Flask-Compress: Flask-Compress (Compress responses in your Flask app with gzip)
-Flask-Compress:
-Flask-Compress: Flask-Compress allows you to easily compress your Flask application's
-Flask-Compress: responses with gzip.
-Flask-Compress:
-Flask-Compress: Homepage: https://github.com/jmcarp/flask-compress
-Flask-Compress:
-Flask-Compress:
-Flask-Compress:
-Flask-Compress:
-Flask-Compress: