summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Andrew Clemons <andrew.clemons@gmail.com>2021-07-25 16:51:59 +1200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-07-25 16:56:07 +0700
commitae87f355db6d7ba14874345d94ca9816217c5cb9 (patch)
tree1b34ef463afa281180900bc39125dd0347ec451e /python
parent43812cf9cc47e7aacce6db1e6be426207f581de2 (diff)
downloadslackbuilds-ae87f355db6d7ba14874345d94ca9816217c5cb9.tar.gz
slackbuilds-ae87f355db6d7ba14874345d94ca9816217c5cb9.tar.xz
python/pygame: Updated for version 2.0.1.
This fixes building on -current. Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pygame/config_unix.patch25
-rw-r--r--python/pygame/pygame.SlackBuild7
-rw-r--r--python/pygame/pygame.info6
3 files changed, 5 insertions, 33 deletions
diff --git a/python/pygame/config_unix.patch b/python/pygame/config_unix.patch
deleted file mode 100644
index d2dc980e6d..0000000000
--- a/python/pygame/config_unix.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- pygame-1.9.6/buildconfig/config_unix.py 2019-09-11 20:29:30.060515857 +0200
-+++ pygame-1.9.6/buildconfig/config_unix.py.orig 2019-09-11 20:29:54.659518227 +0200
-@@ -254,14 +254,14 @@
- for d in DEPS:
- d.configure(incdirs, libdirs)
-
-- for d in DEPS[1:]:
-- if not d.found:
-- if "-auto" not in sys.argv and not confirm("""
--Warning, some of the pygame dependencies were not found. Pygame can still
--compile and install, but games that depend on those missing dependencies
--will not run. Would you like to continue the configuration?"""):
-- raise SystemExit("Missing dependencies")
-- break
-+# for d in DEPS[1:]:
-+# if not d.found:
-+# if "-auto" not in sys.argv and not confirm("""
-+#Warning, some of the pygame dependencies were not found. Pygame can still
-+#compile and install, but games that depend on those missing dependencies
-+#will not run. Would you like to continue the configuration?"""):
-+# raise SystemExit("Missing dependencies")
-+# break
-
- return DEPS
-
diff --git a/python/pygame/pygame.SlackBuild b/python/pygame/pygame.SlackBuild
index c2515c189c..accf72e2d2 100644
--- a/python/pygame/pygame.SlackBuild
+++ b/python/pygame/pygame.SlackBuild
@@ -30,7 +30,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pygame
-VERSION=${VERSION:-1.9.6}
+VERSION=${VERSION:-2.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -85,9 +85,6 @@ find -L . \
# TLDR: Stops packaging scripts from messing with a local PyGame install.
sed -i '/^if "install"/,$d' setup.py
-# Fix warning message for missings dependencies
-patch -p1 < $CWD/config_unix.patch
-
python2 -u buildconfig/config.py
CFLAGS="$SLKCFLAGS" \
python2 setup.py install --root=$PKG
@@ -99,7 +96,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst docs/LGPL $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst docs/LGPL.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/pygame/pygame.info b/python/pygame/pygame.info
index be0ad31955..fd34fa70d6 100644
--- a/python/pygame/pygame.info
+++ b/python/pygame/pygame.info
@@ -1,8 +1,8 @@
PRGNAM="pygame"
-VERSION="1.9.6"
+VERSION="2.0.1"
HOMEPAGE="http://www.pygame.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/0f/9c/78626be04e193c0624842090fe5555b3805c050dfaa81c8094d6441db2be/pygame-1.9.6.tar.gz"
-MD5SUM="36f8817874f9e63acdf12914340b60e9"
+DOWNLOAD="https://files.pythonhosted.org/packages/c7/b8/06e02c7cca7aec915839927a9aa19f749ac17a3d2bb2610b945d2de0aa96/pygame-2.0.1.tar.gz"
+MD5SUM="6353c0eb2367f70b8c8d07d3decc1e46"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="portmidi"