summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dominik Drobek <dominik.drobek (at) o2.pl>2018-08-10 23:29:07 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-08-11 07:23:11 +0700
commitbd4af8b1816ed501e1cec4e0b3b04fe864e03578 (patch)
treeb5f2f03da97af5552349b1b2625a66d366b6bd2a /python
parent764b8881fedcec1c40ec9df424d35970602570a1 (diff)
downloadslackbuilds-bd4af8b1816ed501e1cec4e0b3b04fe864e03578.tar.gz
slackbuilds-bd4af8b1816ed501e1cec4e0b3b04fe864e03578.tar.xz
python/werkzeug: Updated for version 0.14.1 + new maintainer.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/werkzeug/README4
-rw-r--r--python/werkzeug/werkzeug.SlackBuild43
-rw-r--r--python/werkzeug/werkzeug.info10
3 files changed, 29 insertions, 28 deletions
diff --git a/python/werkzeug/README b/python/werkzeug/README
index c1253beb12..6600183012 100644
--- a/python/werkzeug/README
+++ b/python/werkzeug/README
@@ -1,7 +1,7 @@
The Swiss Army knife of Python web development
Werkzeug started as simple collection of various utilities for WSGI
-applications and has become one of the most advanced WSGI utility modules.
+applications and has become one of the most advanced WSGI utility modules.
It includes a powerful debugger, full featured request and response objects,
HTTP utilities to handle entity tags, cache control headers, HTTP dates,
cookie handling, file uploads, a powerful URL routing system and a bunch
@@ -9,7 +9,7 @@ of community contributed addon modules.
Werkzeug is unicode aware and doesn't enforce a specific template engine,
database adapter or anything else. It doesn't even enforce a specific way
-of handling requests and leaves all that up to the developer.
+of handling requests and leaves all that up to the developer.
It's most useful for end user applications which should work on as many
server environments as possible (such as blogs, wikis, bulletin boards, etc)
diff --git a/python/werkzeug/werkzeug.SlackBuild b/python/werkzeug/werkzeug.SlackBuild
index e2e1d8d7c1..a80c334d62 100644
--- a/python/werkzeug/werkzeug.SlackBuild
+++ b/python/werkzeug/werkzeug.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for werkzeug
+# Copyright 2018 Dominik Drobek <dominik.drobek (at) o2.pl>
# Copyright 2013 Mohamed LYAHYAOUI <mlyahyaoui@gmail.com>
# All rights reserved.
#
@@ -11,26 +12,26 @@
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=werkzeug
SRCNAM=Werkzeug
-VERSION=${VERSION:-0.9.4}
+VERSION=${VERSION:-0.14.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -41,10 +42,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="LICENSE PKG-INFO"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -57,6 +56,8 @@ else
LIBDIRSUFFIX=""
fi
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
@@ -68,17 +69,17 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py build || exit 1
+python setup.py build
-python setup.py install --root $PKG || exit 1
+python setup.py install --root $PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGES.rst LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/werkzeug/werkzeug.info b/python/werkzeug/werkzeug.info
index 69aa74a1fa..faf24d53fb 100644
--- a/python/werkzeug/werkzeug.info
+++ b/python/werkzeug/werkzeug.info
@@ -1,10 +1,10 @@
PRGNAM="werkzeug"
-VERSION="0.9.4"
+VERSION="0.14.1"
HOMEPAGE="http://werkzeug.pocoo.org"
-DOWNLOAD="https://pypi.python.org/packages/source/W/Werkzeug/Werkzeug-0.9.4.tar.gz"
-MD5SUM="670fad41f57c13b71a6816765765a3dd"
+DOWNLOAD="https://pypi.python.org/packages/source/W/Werkzeug/Werkzeug-0.14.1.tar.gz"
+MD5SUM="6d20b5be2d245be4ac7706cc390d130c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Mohamed LYAHYAOUI"
-EMAIL="mlyahyaoui@gmail.com"
+MAINTAINER="Dominik Drobek"
+EMAIL="dominik.drobek (at) o2.pl"