summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Andrew Clemons <andrew.clemons@gmail.com>2022-03-12 13:23:00 +1300
committer Andrew Clemons <andrew.clemons@gmail.com>2022-03-12 15:02:07 +1300
commitc08d41def5e3bc862643481121428061ca24862a (patch)
treed4cbe6f51c4d21c156da5d00f277b1559c1d85e4 /python
parenta0b3d789e79d2d3c94c534cfae6dacea2ec05138 (diff)
downloadslackbuilds-c08d41def5e3bc862643481121428061ca24862a.tar.gz
slackbuilds-c08d41def5e3bc862643481121428061ca24862a.tar.xz
python/python3-pyclipper: Fix PRGNAM usage.
Don't introduce new things like PKGNAM. Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>
Diffstat (limited to 'python')
-rw-r--r--python/python3-pyclipper/python3-pyclipper.SlackBuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/python/python3-pyclipper/python3-pyclipper.SlackBuild b/python/python3-pyclipper/python3-pyclipper.SlackBuild
index c96ea0fdb1..f31377f61b 100644
--- a/python/python3-pyclipper/python3-pyclipper.SlackBuild
+++ b/python/python3-pyclipper/python3-pyclipper.SlackBuild
@@ -24,8 +24,8 @@
cd $(dirname $0) ; CWD=$(pwd)
-PRGNAM=pyclipper
-PKGNAM=python3-pyclipper
+PRGNAM=python3-pyclipper
+SRCNAM=${PRGNAM#python3-*}
VERSION=${VERSION:-1.3.0.post2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -43,12 +43,12 @@ fi
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PKGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PKGNAM
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
set -e
@@ -56,9 +56,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -68,12 +68,12 @@ find -L . \
python3 setup.py install --root=$PKG
-mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
-cp -a README.rst LICENSE $PKG/usr/doc/$PKGNAM-$VERSION
-cat $CWD/$PKGNAM.SlackBuild > $PKG/usr/doc/$PKGNAM-$VERSION/$PKGNAM.SlackBuild
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PKGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE