summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Andrew Clemons <andrew.clemons@gmail.com>2020-03-28 15:25:17 +1300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-11-22 09:10:23 +0700
commitd35745de68639ca368fcec018af1d24300b7e996 (patch)
tree627754cca4c1faa51bb592bdba9a3af309af3bd4 /python
parentaebed471b06f8055b329d32bca89372b70fbe03d (diff)
downloadslackbuilds-d35745de68639ca368fcec018af1d24300b7e996.tar.gz
slackbuilds-d35745de68639ca368fcec018af1d24300b7e996.tar.xz
python/rfc6555: Added (Happy Eyeballs in Python).
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/rfc6555/README3
-rw-r--r--python/rfc6555/rfc6555.SlackBuild79
-rw-r--r--python/rfc6555/rfc6555.info10
-rw-r--r--python/rfc6555/slack-desc19
4 files changed, 111 insertions, 0 deletions
diff --git a/python/rfc6555/README b/python/rfc6555/README
new file mode 100644
index 0000000000..7a05a56e71
--- /dev/null
+++ b/python/rfc6555/README
@@ -0,0 +1,3 @@
+Python implementation of the Happy Eyeballs Algorithm described in RFC 6555.
+Provided with a single file and dead-simple API to allow easy vendoring and
+integration into other projects.
diff --git a/python/rfc6555/rfc6555.SlackBuild b/python/rfc6555/rfc6555.SlackBuild
new file mode 100644
index 0000000000..f8a73cbda3
--- /dev/null
+++ b/python/rfc6555/rfc6555.SlackBuild
@@ -0,0 +1,79 @@
+#!/bin/bash
+
+# Slackware build script for rfc6555
+
+# Copyright 2020-2021 Andrew Clemons, Wellingotn New Zealand
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=rfc6555
+VERSION=${VERSION:-0.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/rfc6555/rfc6555.info b/python/rfc6555/rfc6555.info
new file mode 100644
index 0000000000..ba7b1a4841
--- /dev/null
+++ b/python/rfc6555/rfc6555.info
@@ -0,0 +1,10 @@
+PRGNAM="rfc6555"
+VERSION="0.1.0"
+HOMEPAGE="https://pypi.org/project/rfc6555/"
+DOWNLOAD="https://files.pythonhosted.org/packages/f6/4b/24f953c3682c134e4d0f83c7be5ede44c6c653f7d2c0b06ebb3b117f005a/rfc6555-0.1.0.tar.gz"
+MD5SUM="99fd2e4f638151275c9874af18ddc4df"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python2-selectors2"
+MAINTAINER="Andrew Clemons"
+EMAIL="andrew.clemons@gmail.com"
diff --git a/python/rfc6555/slack-desc b/python/rfc6555/slack-desc
new file mode 100644
index 0000000000..264891f572
--- /dev/null
+++ b/python/rfc6555/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+rfc6555: rfc6555 (Python implementation of the Happy Eyeballs Algorithm)
+rfc6555:
+rfc6555: Python implementation of the Happy Eyeballs Algorithm described in
+rfc6555: RFC 6555. Provided with a single file and dead-simple API to allow
+rfc6555: easy vendoring and integration into other projects.
+rfc6555:
+rfc6555:
+rfc6555: Homepage: https://github.com/sethmlarson/rfc6555
+rfc6555:
+rfc6555:
+rfc6555: