summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Prof. HORSTMANN <wmh@eipg.fr>2020-05-14 20:02:53 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-05-16 08:44:11 +0700
commitdf76812c1e0eae30e86cfc73b5e7d0660f844164 (patch)
tree1b7868c2319364da320ff9f263fbee2af216792e /python
parent9c270f89fd886c80e031ff3930f3c923a9f6abb4 (diff)
downloadslackbuilds-df76812c1e0eae30e86cfc73b5e7d0660f844164.tar.gz
slackbuilds-df76812c1e0eae30e86cfc73b5e7d0660f844164.tar.xz
python/xlutils: Added (utilities for working with Excel files)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/xlutils/README46
-rw-r--r--python/xlutils/slack-desc19
-rw-r--r--python/xlutils/xlutils.SlackBuild79
-rw-r--r--python/xlutils/xlutils.info10
4 files changed, 154 insertions, 0 deletions
diff --git a/python/xlutils/README b/python/xlutils/README
new file mode 100644
index 0000000000..2759416d02
--- /dev/null
+++ b/python/xlutils/README
@@ -0,0 +1,46 @@
+A Python package provides a collection of utilities for working with Excel
+files. Since these utilities may require either or both of the xlrd and xlwt
+packages, they are collected together here, separate from either package.
+
+Currently available are:
+
+xlutils.copy
+ Tools for copying xlrd.Book objects to xlwt.Workbook objects.
+xlutils.display
+ Utility functions for displaying information about xlrd-related objects in
+ a user-friendly and safe fashion.
+xlutils.filter
+ A mini framework for splitting and filtering Excel files into new Excel
+ files.
+xlutils.margins
+ Tools for finding how much of an Excel file contains useful data.
+xlutils.save
+ Tools for serializing xlrd.Book objects back to Excel files.
+xlutils.styles
+ Tools for working with formatting information expressed in styles.
+
+Installation
+
+Do the following in your virtualenv:
+
+pip install xlutils
+
+Documentation
+
+The latest documentation can also be found at:
+http://xlutils.readthedocs.org/en/latest/
+
+Problems?
+
+Try the following in this order:
+
+ Read the source
+ Ask a question on http://groups.google.com/group/python-excel/
+
+Licensing
+
+Copyright (c) 2008-2015 Simplistix Ltd. See docs/license.txt for details.
+
+Optional
+
+Python3 support is detected automatically.
diff --git a/python/xlutils/slack-desc b/python/xlutils/slack-desc
new file mode 100644
index 0000000000..0c98fbf16c
--- /dev/null
+++ b/python/xlutils/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+xlutils: xlutils (utilities for working with Excel files)
+xlutils:
+xlutils: Homepage: https://pypi.org/project/xlutils
+xlutils:
+xlutils:
+xlutils:
+xlutils:
+xlutils:
+xlutils:
+xlutils:
+xlutils:
diff --git a/python/xlutils/xlutils.SlackBuild b/python/xlutils/xlutils.SlackBuild
new file mode 100644
index 0000000000..03f955e27a
--- /dev/null
+++ b/python/xlutils/xlutils.SlackBuild
@@ -0,0 +1,79 @@
+#!/bin/sh
+
+# SlackBuild build script for xlutils
+
+# Copyright (c) 2000-2020 Prof. Horstmann <wmh (at) eipg.fr>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Modified by slackbuilds.org
+
+PRGNAM=xlutils
+VERSION=${VERSION:-2.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+ # Python 2.7 will be droped in the future.
+if $(python2 -c 'import sys' 2>/dev/null); then
+ python2 setup.py install --root=$PKG
+fi
+# Replacement of python-2.x Python3.x check presence and build if found.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-txz}
diff --git a/python/xlutils/xlutils.info b/python/xlutils/xlutils.info
new file mode 100644
index 0000000000..656b0c46ac
--- /dev/null
+++ b/python/xlutils/xlutils.info
@@ -0,0 +1,10 @@
+PRGNAM="xlutils"
+VERSION="2.0.0"
+HOMEPAGE="https://pypi.org/project/xlutils"
+DOWNLOAD="https://files.pythonhosted.org/packages/93/fe/af6d73e4bc7b0ce359d34bebb2e8d4d129763acfecd66a3a7efc587e54c9/xlutils-2.0.0.tar.gz"
+MD5SUM="7a6a339ddaacabce244341582ee61353"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Prof. HORSTMANN"
+EMAIL="wmh@eipg.fr"