summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2020-01-03 18:24:22 +0100
committer Robby Workman <rworkman@slackbuilds.org>2021-04-17 23:55:26 -0500
commite92114658051bea078a0ab3e2137494634128ed0 (patch)
treedba524a04dbebda64844c878b3ec1feb97dfa0d6 /python
parentf13212d4181c435f109272d9da71c10abfc21af5 (diff)
downloadslackbuilds-e92114658051bea078a0ab3e2137494634128ed0.tar.gz
slackbuilds-e92114658051bea078a0ab3e2137494634128ed0.tar.xz
python/python3-six: Removed (added to Slackware).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-six/README4
-rw-r--r--python/python3-six/python3-six.SlackBuild76
-rw-r--r--python/python3-six/python3-six.info10
-rw-r--r--python/python3-six/slack-desc19
4 files changed, 0 insertions, 109 deletions
diff --git a/python/python3-six/README b/python/python3-six/README
deleted file mode 100644
index ee25e72d18..0000000000
--- a/python/python3-six/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Six is a Python 2 and 3 compatibility library. It provides utility functions for
-smoothing over the differences between the Python versions with the goal of
-writing Python code that is compatible on both Python versions. See the
-documentation for more information on what is provided.
diff --git a/python/python3-six/python3-six.SlackBuild b/python/python3-six/python3-six.SlackBuild
deleted file mode 100644
index 68d0258a4f..0000000000
--- a/python/python3-six/python3-six.SlackBuild
+++ /dev/null
@@ -1,76 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python3-six
-
-# Copyright 2012-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
-# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python3-six
-VERSION=${VERSION:-1.13.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=six
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGES LICENSE README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-six/python3-six.info b/python/python3-six/python3-six.info
deleted file mode 100644
index 87504ba7b6..0000000000
--- a/python/python3-six/python3-six.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-six"
-VERSION="1.13.0"
-HOMEPAGE="https://pypi.python.org/pypi/six/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/s/six/six-1.13.0.tar.gz"
-MD5SUM="e92c23c882c7d5564ce5773fe31b2771"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-six/slack-desc b/python/python3-six/slack-desc
deleted file mode 100644
index 0694e82700..0000000000
--- a/python/python3-six/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-six: python3-six (Python 2 and 3 compatibility utilities)
-python3-six:
-python3-six: Six is a Python 2 and 3 compatibility library. It provides utility
-python3-six: functions for smoothing over the differences between the Python
-python3-six: versions with the goal of writing Python code that is compatible on
-python3-six: both Python versions. See the documentation for more information on
-python3-six: what is provided.
-python3-six:
-python3-six:
-python3-six:
-python3-six: