summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2011-12-14 16:24:32 -0600
committer Niels Horn <niels.horn@slackbuilds.org>2011-12-18 00:07:50 -0200
commitf66e0fca51d811528bfd49e6595b7de0454afb07 (patch)
tree36d5899d5b2cb00076aed367e325ec8d1a51aa1d /python
parent730402d64b6ccb8bf31b6b96a9348cff574cf301 (diff)
downloadslackbuilds-f66e0fca51d811528bfd49e6595b7de0454afb07.tar.gz
slackbuilds-f66e0fca51d811528bfd49e6595b7de0454afb07.tar.xz
python/pyasn1: Miscellaneous tweaks/cleanups
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pyasn1/README8
-rw-r--r--python/pyasn1/pyasn1.SlackBuild6
-rw-r--r--python/pyasn1/pyasn1.info2
-rw-r--r--python/pyasn1/slack-desc8
4 files changed, 8 insertions, 16 deletions
diff --git a/python/pyasn1/README b/python/pyasn1/README
index 9f0c7dbd37..e8c7885ff0 100644
--- a/python/pyasn1/README
+++ b/python/pyasn1/README
@@ -1,7 +1 @@
-pyasn1 implements ASN.1 types and codecs (BER, CER, DER) in Python
-
-Its features are:
-- Generic implementation of ASN.1 types (X.208)
-- Fully standard compliant BER/CER/DER codecs
-- 100% Python, works with Python 2.2 and later
-- MT-safe
+pyasn1 implements ASN.1 types and codecs (BER, CER, DER) in Python.
diff --git a/python/pyasn1/pyasn1.SlackBuild b/python/pyasn1/pyasn1.SlackBuild
index fb55772dbe..8a55495b4b 100644
--- a/python/pyasn1/pyasn1.SlackBuild
+++ b/python/pyasn1/pyasn1.SlackBuild
@@ -21,7 +21,7 @@
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
+
# markus reichelt, slackbuilds@mareichelt.de, 0xCCEEF115
# 2011 September 04 - initial release
@@ -72,8 +72,7 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py build || exit 1
-python setup.py install --root=$PKG || exit 1
+python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -82,7 +81,6 @@ mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
README THANKS TODO CHANGES LICENSE \
$PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/slack-desc > $PKG/usr/doc/$PRGNAM-$VERSION/slack-desc
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/pyasn1/pyasn1.info b/python/pyasn1/pyasn1.info
index 3951640593..f35a1a4738 100644
--- a/python/pyasn1/pyasn1.info
+++ b/python/pyasn1/pyasn1.info
@@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="markus reichelt"
EMAIL="slackbuilds@mareichelt.de"
-APPROVED="Erik Hanson"
+APPROVED="rworkman"
diff --git a/python/pyasn1/slack-desc b/python/pyasn1/slack-desc
index 89be00aed7..b3c6f2f854 100644
--- a/python/pyasn1/slack-desc
+++ b/python/pyasn1/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':'.
|-----handy-ruler----------------------------------------------------|
-pyasn1: pyasn1 (implements ASN.1 types and codecsin Python)
+pyasn1: pyasn1 (ASN.1 types and codecs in Python)
pyasn1:
-pyasn1: Features:
+pyasn1: pyasn1 implements ASN.1 types and codecs (BER, CER, DER) in Python.
+pyasn1:
+pyasn1: Some features include:
pyasn1: - Generic implementation of ASN.1 types (X.208)
pyasn1: - Fully standard compliant BER/CER/DER codecs
pyasn1: - 100% Python, works with Python 2.2 and later
-pyasn1: - MT-safe
pyasn1:
pyasn1: Homepage: http://sourceforge.net/projects/pyasn1/
pyasn1:
-pyasn1: