summaryrefslogtreecommitdiffstats
path: root/system/I-Nex
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-02-12 01:52:44 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-13 09:17:47 +0700
commit796734e0065a69cf7c84e1ed8f1b93c346b91e9d (patch)
tree1f5aa21f14097a16ae4d1a04502cda55b44b8469 /system/I-Nex
parentf7675814a6056b12d6721aa341239faf4ca114d3 (diff)
downloadslackbuilds-796734e0065a69cf7c84e1ed8f1b93c346b91e9d.tar.gz
slackbuilds-796734e0065a69cf7c84e1ed8f1b93c346b91e9d.tar.xz
system/I-Nex: Various fixes.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/I-Nex')
-rw-r--r--system/I-Nex/I-Nex.SlackBuild28
1 files changed, 18 insertions, 10 deletions
diff --git a/system/I-Nex/I-Nex.SlackBuild b/system/I-Nex/I-Nex.SlackBuild
index c72e66befd..d45e04499d 100644
--- a/system/I-Nex/I-Nex.SlackBuild
+++ b/system/I-Nex/I-Nex.SlackBuild
@@ -22,11 +22,17 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220212 bkw: Modified by SlackBuilds.org: BUILD=2.
+# - add -j1 to 'make install' to avoid breaking parallel builds.
+# - fix the .desktop files
+# - install the rest of the docs (AUTHORS, ChangeLog).
+# - don't install useless INSTALL to doc dir.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=I-Nex
VERSION=${VERSION:-7.6.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +44,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,9 +78,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
sed -i -e 's|^STATIC.*|STATIC = false|' i-nex.mk
@@ -96,15 +99,20 @@ CFLAGS="$SLKCFLAGS" \
cd ..
make
-make install DESTDIR=$PKG
+make -j1 install DESTDIR=$PKG
+strip $PKG/usr/bin/i-nex-edid
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# the shipped .desktop files don't validate, and are silly. also they
+# get installed executable...
+for i in $CWD/*.desktop; do
+ cat $i > $PKG/usr/share/applications/$( basename $i )
+done
+rm -rf $PKG/usr/share/doc
mv $PKG/usr/share/man/ $PKG/usr/
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $PRGNAM/COPYING $PRGNAM/INSTALL $PRGNAM/README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $PRGNAM/{AUTHORS,COPYING,ChangeLog,README} $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install