summaryrefslogtreecommitdiffstats
path: root/system/borgbackup
diff options
context:
space:
mode:
author Andrzej Telszewski <atelszewski@gmail.com>2016-08-19 19:12:43 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-20 07:49:48 +0700
commit4c4becaf35dc452ab6f4c3d97869ab2ef26731f0 (patch)
tree6d074d7a1c66a70aa4581c9ab22650e8929664d1 /system/borgbackup
parent9d9ad1f005d3989b343319e990b860d11ed7cc7b (diff)
downloadslackbuilds-4c4becaf35dc452ab6f4c3d97869ab2ef26731f0.tar.gz
slackbuilds-4c4becaf35dc452ab6f4c3d97869ab2ef26731f0.tar.xz
system/borgbackup: Added (deduplicating backup program).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/borgbackup')
-rw-r--r--system/borgbackup/README17
-rw-r--r--system/borgbackup/borgbackup.SlackBuild96
-rw-r--r--system/borgbackup/borgbackup.info10
-rw-r--r--system/borgbackup/slack-desc19
-rw-r--r--system/borgbackup/unicode_docs.patch13
5 files changed, 155 insertions, 0 deletions
diff --git a/system/borgbackup/README b/system/borgbackup/README
new file mode 100644
index 0000000000..1f5f145647
--- /dev/null
+++ b/system/borgbackup/README
@@ -0,0 +1,17 @@
+BorgBackup (short: Borg) is a deduplicating backup program.
+Optionally, it supports compression and authenticated encryption.
+
+The main goal of Borg is to provide an efficient and secure way to backup data.
+The data deduplication technique used makes Borg suitable for daily backups
+since only changes are stored. The authenticated encryption technique makes it
+suitable for backups to not fully trusted targets.
+
+Borg is a fork of Attic and is maintained by "The Borg collective".
+
+Optional dependencies:
+- llfuse (https://slackbuilds.org/apps/llfuse/) is required,
+ if you wish to mount an archive as a FUSE filesystem,
+- Sphinx (https://slackbuilds.org/apps/Sphinx/) and
+ sphinx_rtd_theme (https://slackbuilds.org/apps/sphinx_rtd_theme/) are
+ required if you wish to build the docs (man, html). Please note that the
+ build will fail if Sphinx is installed, but sphinx_rtd_theme is not.
diff --git a/system/borgbackup/borgbackup.SlackBuild b/system/borgbackup/borgbackup.SlackBuild
new file mode 100644
index 0000000000..052b3343f1
--- /dev/null
+++ b/system/borgbackup/borgbackup.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/sh
+
+# Slackware build script for borgbackup
+
+# Copyright 2016 Andrzej Telszewski, Banie
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=borgbackup
+VERSION=${VERSION:-1.0.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+if [ -x /usr/bin/sphinx-build ]; then
+ cd docs
+ patch -p0 < $CWD/unicode_docs.patch
+ make html man
+ cp -a _build/html $PKG/usr/doc/$PRGNAM-$VERSION
+ mkdir -p $PKG/usr/man/man1
+ cp -a _build/man/borg.1 $PKG/usr/man/man1
+ gzip -9 $PKG/usr/man/man1/borg.1
+ cd ..
+fi
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/borgbackup/borgbackup.info b/system/borgbackup/borgbackup.info
new file mode 100644
index 0000000000..622ecb4678
--- /dev/null
+++ b/system/borgbackup/borgbackup.info
@@ -0,0 +1,10 @@
+PRGNAM="borgbackup"
+VERSION="1.0.6"
+HOMEPAGE="https://borgbackup.readthedocs.io/"
+DOWNLOAD="https://github.com/borgbackup/borg/releases/download/1.0.6/borgbackup-1.0.6.tar.gz"
+MD5SUM="4434e111e90e6bac7181e44cc580f83c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3 lz4 msgpack-python"
+MAINTAINER="Andrzej Telszewski"
+EMAIL="atelszewski@gmail.com"
diff --git a/system/borgbackup/slack-desc b/system/borgbackup/slack-desc
new file mode 100644
index 0000000000..f58dca23e6
--- /dev/null
+++ b/system/borgbackup/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+borgbackup: borgbackup (deduplicating backup program)
+borgbackup:
+borgbackup: BorgBackup (short: Borg) is a deduplicating backup program.
+borgbackup: Optionally, it supports compression and authenticated encryption.
+borgbackup: The main goal of Borg is to provide an efficient and secure way
+borgbackup: to backup data. The data deduplication technique used makes Borg
+borgbackup: suitable for daily backups since only changes are stored. The
+borgbackup: authenticated encryption technique makes it suitable for backups
+borgbackup: to not fully trusted targets.
+borgbackup:
+borgbackup: Homepage: https://borgbackup.readthedocs.io/
diff --git a/system/borgbackup/unicode_docs.patch b/system/borgbackup/unicode_docs.patch
new file mode 100644
index 0000000000..e70e77af17
--- /dev/null
+++ b/system/borgbackup/unicode_docs.patch
@@ -0,0 +1,13 @@
+--- conf.py.orig 2016-08-17 20:36:40.160264073 +0200
++++ conf.py 2016-08-17 20:36:12.631648017 +0200
+@@ -43,8 +43,8 @@
+ master_doc = 'index'
+
+ # General information about the project.
+-project = 'Borg - Deduplicating Archiver'
+-copyright = '2010-2014 Jonas Borgström, 2015-2016 The Borg Collective (see AUTHORS file)'
++project = u'Borg - Deduplicating Archiver'
++copyright = u'2010-2014 Jonas Borgström, 2015-2016 The Borg Collective (see AUTHORS file)'
+
+ # The version info for the project you're documenting, acts as replacement for
+ # |version| and |release|, also used in various other places throughout the