summaryrefslogtreecommitdiffstats
path: root/system/glances
diff options
context:
space:
mode:
author Philip Lacroix <philnx[at]bluebottle[dot]com>2013-11-30 16:27:55 +0100
committer Robby Workman <rworkman@slackbuilds.org>2013-12-02 00:58:00 -0600
commit7a3cfd7ff4bd29955f07de756e2155e72cd7e8df (patch)
tree7d87ce4bd81afc43f4cfb4903179d31f4791f3e3 /system/glances
parent3bbf957da1a7c955d89a9ce672e2444e5db38268 (diff)
downloadslackbuilds-7a3cfd7ff4bd29955f07de756e2155e72cd7e8df.tar.gz
slackbuilds-7a3cfd7ff4bd29955f07de756e2155e72cd7e8df.tar.xz
system/glances: Added (curses-based monitoring tool).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'system/glances')
-rw-r--r--system/glances/README17
-rw-r--r--system/glances/doinst.sh14
-rw-r--r--system/glances/glances.SlackBuild84
-rw-r--r--system/glances/glances.info10
-rw-r--r--system/glances/slack-desc19
5 files changed, 144 insertions, 0 deletions
diff --git a/system/glances/README b/system/glances/README
new file mode 100644
index 0000000000..501b368e6a
--- /dev/null
+++ b/system/glances/README
@@ -0,0 +1,17 @@
+Glances is a free (LGPL) cross-platform curses-based monitoring tool
+which aims to present a maximum of information in a minimum of space,
+ideally to fit in a classical 80x24 terminal or higher to have addi-
+tionnal information.
+
+Glances can adapt dynamically the displayed information depending on
+the terminal size. It can also work in a client/server mode for remote
+monitoring.
+
+This tool is written in Python and uses the psutil library to fetch the
+statistical values from key elements, like CPU, load average, memory,
+network, disks, file systems, processes, etc.
+
+Optional dependencies are Jinja2 (for HTML output), hddtemp (for HHD
+temperature monitoring support) and python3.
+Others not available on SBo are pysensors (for HW monitoring support)
+and batinfo (for battery monitoring support).
diff --git a/system/glances/doinst.sh b/system/glances/doinst.sh
new file mode 100644
index 0000000000..3ec38c6c20
--- /dev/null
+++ b/system/glances/doinst.sh
@@ -0,0 +1,14 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+config etc/glances/glances.conf.new
diff --git a/system/glances/glances.SlackBuild b/system/glances/glances.SlackBuild
new file mode 100644
index 0000000000..588f4c3a81
--- /dev/null
+++ b/system/glances/glances.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for glances
+
+# Copyright 2013 Philip Lacroix <philnx@bluebottle.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=glances
+VERSION=${VERSION:-1.7.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/v$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Python 3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+# don't clobber configuration files
+mv $PKG/etc/$PRGNAM/$PRGNAM.conf $PKG/etc/$PRGNAM/$PRGNAM.conf.new
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr/
+gzip -9 $PKG/usr/man/man?/*.?
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mv $PKG/usr/share/doc/$PRGNAM/* $PKG/usr/doc/$PRGNAM-$VERSION
+rm -rf $PKG/usr/share/doc
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/glances/glances.info b/system/glances/glances.info
new file mode 100644
index 0000000000..850a5f5027
--- /dev/null
+++ b/system/glances/glances.info
@@ -0,0 +1,10 @@
+PRGNAM="glances"
+VERSION="1.7.2"
+HOMEPAGE="https://github.com/nicolargo/glances"
+DOWNLOAD="https://github.com/nicolargo/glances/archive/v1.7.2.tar.gz"
+MD5SUM="71fe3c9be2490095e8eeb07f172ffe2e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="psutil pysetuptools"
+MAINTAINER="Philip Lacroix"
+EMAIL="philnx[at]bluebottle[dot]com"
diff --git a/system/glances/slack-desc b/system/glances/slack-desc
new file mode 100644
index 0000000000..a7ccad9d9b
--- /dev/null
+++ b/system/glances/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+glances: glances (a cross-platform curses-based monitoring tool)
+glances:
+glances: glances is a cross-platform curses-based monitoring tool written in
+glances: Python, which can adapt the displayed information depending on the
+glances: terminal size. It can also work in a client/server mode for remote
+glances: monitoring.
+glances: glances uses the psutil library to get information from your system.
+glances:
+glances: Homepage: https://github.com/nicolargo/glances
+glances:
+glances: