summaryrefslogtreecommitdiffstats
path: root/system/nvidia-legacy96-driver/Makefile-libXNVCtrl
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@liwjatan.at>2011-01-09 12:52:22 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-01-10 15:04:45 -0600
commit71cf248a4e57ec0ccaac6ca11a0a739aebfcff48 (patch)
tree87ce7f5ec414e3552f07525191438074a5c90c18 /system/nvidia-legacy96-driver/Makefile-libXNVCtrl
parenta68e9505cbe8a7c507a31b512c46176d0c261068 (diff)
downloadslackbuilds-71cf248a4e57ec0ccaac6ca11a0a739aebfcff48.tar.gz
slackbuilds-71cf248a4e57ec0ccaac6ca11a0a739aebfcff48.tar.xz
system/nvidia-legacy96-driver: Updated for version 96.43.19.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'system/nvidia-legacy96-driver/Makefile-libXNVCtrl')
-rw-r--r--system/nvidia-legacy96-driver/Makefile-libXNVCtrl32
1 files changed, 32 insertions, 0 deletions
diff --git a/system/nvidia-legacy96-driver/Makefile-libXNVCtrl b/system/nvidia-legacy96-driver/Makefile-libXNVCtrl
new file mode 100644
index 0000000000..15b03cc3ee
--- /dev/null
+++ b/system/nvidia-legacy96-driver/Makefile-libXNVCtrl
@@ -0,0 +1,32 @@
+# Copyright (c) 2008 NVIDIA, Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+RANLIB ?= ranlib
+
+libXNVCtrl.a : libXNVCtrl.a(NVCtrl.o)
+ $(RANLIB) $@
+
+NVCtrl.o : NVCtrl.h nv_control.h NVCtrlLib.h
+.INTERMEDIATE: NVCtrl.o
+
+clean ::
+ rm -f libXNVCtrl.a *.o
+.PHONY: clean