summaryrefslogtreecommitdiffstats
path: root/system/pass-import
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2022-02-14 12:39:43 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-16 09:11:59 +0700
commit62e0dd7fcae9a6ded0d989d7b72a07ab277ff7ef (patch)
treead2fbb69eebddf8aa4f42b2e47f002cf796bbc0f /system/pass-import
parentc67c21b279dc57b1ae64551e5085d3b9f3028947 (diff)
downloadslackbuilds-62e0dd7fcae9a6ded0d989d7b72a07ab277ff7ef.tar.gz
slackbuilds-62e0dd7fcae9a6ded0d989d7b72a07ab277ff7ef.tar.xz
system/pass-import: Upload pass-import
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/pass-import')
-rw-r--r--system/pass-import/README2
-rw-r--r--system/pass-import/pass-import.SlackBuild98
-rw-r--r--system/pass-import/pass-import.info10
-rw-r--r--system/pass-import/slack-desc19
4 files changed, 129 insertions, 0 deletions
diff --git a/system/pass-import/README b/system/pass-import/README
new file mode 100644
index 0000000000..aac83b761f
--- /dev/null
+++ b/system/pass-import/README
@@ -0,0 +1,2 @@
+pass import is a pass extension for importing data from most of the
+existing password manager.
diff --git a/system/pass-import/pass-import.SlackBuild b/system/pass-import/pass-import.SlackBuild
new file mode 100644
index 0000000000..f8cfa4404c
--- /dev/null
+++ b/system/pass-import/pass-import.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/sh
+
+# Slackware build script for pass-import
+
+# Copyright 2021-2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=pass-import
+VERSION=${VERSION:-3.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/share/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/share/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.rst CONTRIBUTING.rst LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/pass-import/pass-import.info b/system/pass-import/pass-import.info
new file mode 100644
index 0000000000..1b2bd62285
--- /dev/null
+++ b/system/pass-import/pass-import.info
@@ -0,0 +1,10 @@
+PRGNAM="pass-import"
+VERSION="3.2"
+HOMEPAGE="https://github.com/roddhjav/pass-import"
+DOWNLOAD="https://github.com/roddhjav/pass-import/releases/download/v3.2/pass-import-3.2.tar.gz"
+MD5SUM="d94c65a2eadb01dda9db5527e8b533d2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="password-store"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/system/pass-import/slack-desc b/system/pass-import/slack-desc
new file mode 100644
index 0000000000..80ad3c49a7
--- /dev/null
+++ b/system/pass-import/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pass-import: pass-import (pass extension)
+pass-import:
+pass-import: pass import is a pass extension for importing data from most of the
+pass-import: existing password manager.
+pass-import:
+pass-import:
+pass-import:
+pass-import:
+pass-import:
+pass-import:
+pass-import: